After installation of COmmunity Server only Document server Welcome page

Issues during installation and related to database
Post Reply
mouille
Posts: 4
Joined: Sun Mar 15, 2020 12:02 pm

After installation of COmmunity Server only Document server Welcome page

Post by mouille » Sun Mar 15, 2020 12:11 pm

Hello,

I've installed Community Server on Linux Ubuntu 18.04 LTS with the script in mode DEB packages.
The script finished saying the installation was successful but when I open navigator with my URL, I get only the Document server Welcome page saying Document Server works.
What is the problem ? What have I forgot to do please ?
Thanks.

JPM

Carl
Posts: 311
Joined: Thu Apr 12, 2018 10:00 am

Re: After installation of COmmunity Server only Document server Welcome page

Post by Carl » Mon Mar 16, 2020 9:32 am

Hello JPM,

Please go to /etc/onlyoffice/documentserver/nginx/ds.conf and check the section below:
listen 0.0.0.0:8083;
listen [::]:8083 default_server;

If the number in bold is 80 instead of 8083, change it to 8083 in both lines and run service nginx reload and supervisorctl restart all. After that try accessing the portal.

mouille
Posts: 4
Joined: Sun Mar 15, 2020 12:02 pm

Re: After installation of COmmunity Server only Document server Welcome page

Post by mouille » Fri Mar 20, 2020 12:55 pm

Hi,

Thanks for answering, here is the content of my ds.conf :

include /etc/nginx/includes/http-common.conf;
server {
listen 0.0.0.0:8083;
listen [::]:8083 default_server;
server_tokens off;

include /etc/nginx/includes/ds-*.conf;
}
server {
listen 0.0.0.0:8083;
listen [::]:8083 ;
server_tokens off;

include /etc/nginx/includes/ds-*.conf;

server_name collab.almdc.fr; # managed by Certbot

listen [::]:443 ssl ipv6only=on; # managed by Certbot
listen 443 ssl; # managed by Certbot
ssl_certificate /etc/letsencrypt/live/collab.almdc.fr/fullchain.pem; # managed by Certbot
ssl_certificate_key /etc/letsencrypt/live/collab.almdc.fr/privkey.pem; # managed by Certbot
include /etc/letsencrypt/options-ssl-nginx.conf; # managed by Certbot
ssl_dhparam /etc/letsencrypt/ssl-dhparams.pem; # managed by Certbot

}

No change
Thanks.

Carl
Posts: 311
Joined: Thu Apr 12, 2018 10:00 am

Re: After installation of COmmunity Server only Document server Welcome page

Post by Carl » Fri Mar 20, 2020 1:43 pm

Hello mouille,

Please give me the link to the guide you used to install the product. Also I see this
managed by Certbot
did you let Certbot change the configs to switch to HTTPS? This is incorrect. All the instructions about enabling HTTPS are available in our Helpcenter. You need to follow these instructions.

mouille
Posts: 4
Joined: Sun Mar 15, 2020 12:02 pm

Re: After installation of COmmunity Server only Document server Welcome page

Post by mouille » Sat Mar 21, 2020 1:20 pm

Hi,

Here is the link : https://helpcenter.onlyoffice.com/fr/se ... ation.aspx

I'm looking at https instructions.

Regards.
JPM

mouille
Posts: 4
Joined: Sun Mar 15, 2020 12:02 pm

Re: After installation of COmmunity Server only Document server Welcome page

Post by mouille » Fri Mar 27, 2020 8:34 am

Hi,

I finally succeed to install Community Server, but I must give you these information on installation script for Ubuntu 18.04, not mentioned in script web page:
- First you have to add keys of Ubuntu and Onlyoffice, and repository of Onlyoffice
- You have before to make www-data (nginx/Apache user) as owner of /var/www directory (chown command). If you do not, the script will fail, and when you restart after this done, the product is said as installed but is not.
- I had to reinitialize the VM each time because I didn't see an uninstall option of the script an even I uninstall manually I couldn't reinstall

Thanks for the help you gave to me.
Best regards.

JPM

Post Reply