Is swap memory really a hard requirement?

Issues during installation and related to database
Post Reply
onlyofficefan
Posts: 3
Joined: Sun Feb 02, 2020 5:28 pm

Is swap memory really a hard requirement?

Post by onlyofficefan » Sun Feb 02, 2020 5:48 pm

Hi everybody,

new here. :-)

I am using a V-Server with 8 GB of RAM, 4 CPU vCores and 100 GB SSD. OS is Debian 9. According to the Only Office site the requirements for swap is 4 GB and 2 GB of RAM. Unfortunately my V-Server doesn't allow a swap partition.

The question is: Is the swap file /partition a hard requirement? With 8 GB I am far above the requirement for RAM.

JC

Alexandre
Posts: 59
Joined: Thu Dec 12, 2019 11:08 am

Re: Is swap memory really a hard requirement?

Post by Alexandre » Mon Feb 03, 2020 12:39 pm

Hello onlyofficefan.
It's a bit strange. Usually virtual servers support swap. Could you please run installation scripts from our site and check if any error occurs while the installation proceeds.
If the error doesn't occur, run command free -h from host. You should see swap storage after our script is done.

onlyofficefan
Posts: 3
Joined: Sun Feb 02, 2020 5:28 pm

Re: Is swap memory really a hard requirement?

Post by onlyofficefan » Tue Feb 04, 2020 10:07 pm

Hi Alexandre,

Thanks for your support! :-)

which script do you mean exactly? The error I am receiving is as followed:

Installing collected packages: app-rights-plugin
Successfully installed app-rights-plugin-0.1.0
/var/lib/dpkg/info/onlyoffice-communityserver.postinst: 333: /var/lib/dpkg/info/
onlyoffice-communityserver.postinst: arithmetic expression: expecting primary: " * "
dpkg: Fehler beim Bearbeiten des Paketes onlyoffice-communityserver (--configure ):
Unterprozess installiertes post-installation-Skript gab den Fehlerwert 2 zurück
Trigger für libc-bin (2.24-11+deb9u4) werden verarbeitet ...
Trigger für systemd (232-25+deb9u12) werden verarbeitet ...
Fehler traten auf beim Bearbeiten von:
onlyoffice-communityserver
E: Sub-process /usr/bin/dpkg returned an error code (1)

Maybe you have an idea where things are blocking. Do you know where I can more details on the mistake? I ran my installation procedure in a Virtualbox with the same OS. Worked like a treat. Then ran the same on the same without the swap partition. It worked also like a treat. It seems that the VServer has something missing I have overseen.

Here the free -g:

root@h2867113:~# free -g
total used free shared buff/cache available
Mem: 8 0 6 0 0 7
Swap: 0 0 0

Greentings,

JC

Alexandre
Posts: 59
Joined: Thu Dec 12, 2019 11:08 am

Re: Is swap memory really a hard requirement?

Post by Alexandre » Thu Feb 06, 2020 1:56 pm

Hello.
which script do you mean exactly?
I mean script from category “For Debian“ from our site. You can find it here: https://helpcenter.onlyoffice.com/serve ... ation.aspx
Please specify, if you tried another script.

onlyofficefan
Posts: 3
Joined: Sun Feb 02, 2020 5:28 pm

Re: Is swap memory really a hard requirement?

Post by onlyofficefan » Sat Feb 08, 2020 9:13 pm

Hi Alexandre,

when I first installed only Office it was via "Hand".

I tried the script For-Debian as follows:

Code: Select all

bash install-Debian.sh -os true
And got this:

Code: Select all

Setting up mono-complete (6.0.0.334-0xamarin1+debian9b1) ...
Processing triggers for libc-bin (2.24-11+deb9u4) ...
Processing triggers for systemd (232-25+deb9u12) ...
Processing triggers for libgdk-pixbuf2.0-0:amd64 (2.36.5-2+deb9u2) ...
Errors were encountered while processing:
 rabbitmq-server
E: Sub-process /usr/bin/dpkg returned an error code (1)
It seems that I have an error produced while installing rabbitmq.

I am going to run the "bash opensource-install.sh" as I believe I get better feedback on the error.

JC

Alexandre
Posts: 59
Joined: Thu Dec 12, 2019 11:08 am

Re: Is swap memory really a hard requirement?

Post by Alexandre » Mon Feb 17, 2020 3:31 pm

Hello.
Did you try to install ONLYOFFICE on “clean” server?
By the way, tell me please full information about your V-Server. 

Post Reply