Third party service integration - OneDrive

Tech support for Enterprise Version
Post Reply
cantabrico
Posts: 16
Joined: Wed Apr 19, 2017 5:24 pm

Third party service integration - OneDrive

Post by cantabrico » Fri Oct 19, 2018 8:45 am

Hello.

I connected the One Drive API and I have the following problem:

API does not work with OneDrive for Business. Login is running at https://login.live.com/ but there is no login with bussines email.

If I add private email, the login is OK, but when I create a folder, I will see:
The remote server has returned an error: (400) Bad Request.

Carl
Posts: 122
Joined: Thu Apr 12, 2018 10:00 am

Re: Third party service integration - OneDrive

Post by Carl » Fri Oct 26, 2018 12:14 pm

Hello,

Please describe how you connected your OneDrive account step by step. What instruction have you used?

cantabrico
Posts: 16
Joined: Wed Apr 19, 2017 5:24 pm

Re: Third party service integration - OneDrive

Post by cantabrico » Tue Oct 30, 2018 8:20 am

I joined using the tutorial here:
https://helpcenter.onlyoffice.com/serve ... -keys.aspx

Some data are no longer up to date (changed web), so I proceeded as follows:

After login address is:
https://apps.dev.microsoft.com/?mkt=sk- ... reate/sapi

Add an app
Application Name -> Test
Create
Now I have Aplication ID

Application Secrets -> Generate New password ->OK
Now I have password

Platforms -> Add Platform -> Web
In Redirect url I paste: https://service.onlyoffice.com/oauth2.aspx
Save

Now I insert Client ID and password to settings in my OO

I go to Doccument add new One Drive account

My working company email - not exist
My private no company email - exist and plugin working
Attachments
OO-onedrive.png
OO-onedrive.png (20.27 KiB) Viewed 513 times

Maxim
Posts: 1844
Joined: Tue Oct 11, 2016 2:34 pm

Re: Third party service integration - OneDrive

Post by Maxim » Thu Feb 14, 2019 7:15 am

Hello cantabrico!
Try to connect like Sharepoint.
Also take a look at logs. is there any error?

cantabrico
Posts: 16
Joined: Wed Apr 19, 2017 5:24 pm

Re: Third party service integration - OneDrive

Post by cantabrico » Thu Feb 14, 2019 9:11 am

In connector i have only OneDrive. It is correct?
Image

Address for login from OO OneDrive conector is:
https://login.live.com/oauth20_authoriz ... e=https%3a
But my account not working on login.live.com - address is for non company email
Image

When a logged from browser in
office.com or https://login.microsoftonline.com my comapny email exist.

I do not have any logs because it shows me that my email does not exist.

When in browser I add login email in:
login.live.com - email not exist

When I add email in this adress:
https://account.live.com/developers/applications/create
it automatic redirect to add password
https://login.microsoftonline.com for
and login working

Post Reply