Community Server 10.0.1

Community Server releases and description of the update.
Locked
Maxim
Posts: 2017
Joined: Tue Oct 11, 2016 2:34 pm

Community Server 10.0.1

Post by Maxim » Fri May 31, 2019 11:47 am

Community Server changelog
Community Server on our blog.
The new version of ONLYOFFICE with lots of enhancements is now available for the users of ONLYOFFICE server solutions. Welcome more security tools, new access rights to documents, completely upgraded mail and calendar, improved LDAP, and other features. Here is a brief overview of what’s new.

Documents module
  • Added the possibility to view AVI, MPEG and MPG files;
    If the portal has HTTPS enabled, the address of the editors is also checked for the presense of the secure HTTPS connection alternative.
People module
Added the restriction for the number of all users (both active and guests) on the portal.

Mail Server
New features
  • Added permanent Fail2Ban ignoreip section for docker containers and its gateway;
    Added the possibility to create sieve rules for users inside /var/vmail/sieve/;
    Added new extension to sieve: sieve_extensions -> editheader;
    Exposed port 4190 for ManageSieve service;
    Added the possibility to run an external script from the /var/vmail/external.sh or /app/onlyoffice/MailServer/data/external.sh path;
    Changed the default FIRST_DOMAIN parameter;
    Replaced the hard-coded password used for the first mailbox with a random one;
    Removed old useless descriptions for iRedMail administrator console path;
    Added backticks to the 'CREATE DATABASE' commands;
    Added the possibility to send mail messages from alias_domain, alias_address and full alias;
    Added the imapsync command;
    Added the new Python scripts allowing to create mailboxes, change password and run imapsync batch in /usr/src/iRedMail/tools/scripts folder inside the onlyoffice-mail-server container;
    Added the Python PIP manager and installation requirements.
Bug fixes
  • Fixed the bug with mailbox not being removed when using third level domain (issue: wrong domain regex);
    Fixed the bug with the Cannot load 1024-bit DH parameters from file /etc/pki/tls/dhparams.pem warning;
    Fixed the bug with the No such file or directory being shown in many cases;
    Fixed the bug with the ECHO_INFO: command not found warning.

Locked