Proxy -> Virtualpath setup not working for cache mapping?

Suggestions on Document Server Installation/Functionality
Post Reply
threeleaves
Posts: 2
Joined: Wed Dec 13, 2017 4:39 am

Proxy -> Virtualpath setup not working for cache mapping?

Post by threeleaves » Tue Aug 28, 2018 7:23 am

I've followed the proxy -> virtualpath setup instructions.

We've got an apache server proxying to our docker instance so:

Code: Select all

https://server1/office/  proxies to ->  http://dockerinstance/office/
have setup location as follows:

Code: Select all

location /office / {
 proxy_pass http://default/;
}

upstream default {
 server nameofserver;
}
Originally i copied the example file exactly (mapping proxy_pass to http://docservice/) and docservice being nameofserver:8000;

the error I got with the example was that docservice loaded but spellchecker and cache did not

with my current setup docservice loads and spellchecker loads

but for some reason, cache is loading from the baseURL

eg: its trying to get cache from: https://server1/cache/files/blah/blah/blah when it should be https://server1/office/cache/files/blah/blah/blah

Whats the solution to this?

i've tried to setup a rewrite in onlyoffice-documentserver-docservice.conf like this:

Code: Select all

rewrite ^(\/cache\/files\/)(.*)$ $the_scheme://$the_host/office/cache/files/$2 redirect;
but it doesnt work.

Is there a config parameter to change the default mapping of the cache server call? Or is there a better way to set a custom root than my example?

Maxim
Posts: 1786
Joined: Tue Oct 11, 2016 2:34 pm

Re: Proxy -> Virtualpath setup not working for cache mapping

Post by Maxim » Fri Aug 31, 2018 7:12 am

Hello threeleaves!
Maybe this (Document Server example configurations for proxy) will help you

Post Reply