Unknown error when loading document editor.

Integration questions/issues
Post Reply
laruladh
Posts: 1
Joined: Fri Feb 19, 2016 11:06 am

Unknown error when loading document editor.

Post by laruladh » Fri Feb 19, 2016 11:17 am

Hi,

I have the latest version of the document server running on a Ubuntu 14.04 box. Inside my web app I have the following configured:

Code: Select all

<div id="placeholder"></div>

<script type="text/javascript" src="http://onlyoffice.myserver.local/OfficeWeb/apps/api/documents/api.js"></script>
	<script type="text/javascript">
		$( document ).ready(function() {
	    var docEditor = new DocsAPI.DocEditor('placeholder', {
	    	height: '1000px',
		    documentType: 'text',
		    document: {
	        fileType: 'docx',
	        key: 'Khirz6zTPdfd7',
	        title: 'Example Document Title.docx',
	        url: 'https://demo.myserver.local/memo.docx',
	  	  },
	    	editorConfig: {
	    	}
	  	});
		});
	</script>
However when I load the page I get a popup dialog "Unknown error" (see attached). And a 502 Bad Gateway error in the browser console:

Code: Select all

Synchronous XMLHttpRequest on the main thread is deprecated because of its detrimental effects to the end user's experience. For more help, check https://xhr.spec.whatwg.org/.
'CanvasRenderingContext2D.webkitImageSmoothingEnabled' is deprecated. Please use 'CanvasRenderingContext2D.imageSmoothingEnabled' instead.
POST http://onlyoffice.myserver.local/CanvasService.ashx 502 (Bad Gateway)
I'm a bit lost as to what exactly is going on so would appreciate any assistance on this. Thanks in advance.
Attachments
error.jpeg
Unknow error dialog
error.jpeg (6.72 KiB) Viewed 1778 times

Dean
Posts: 700
Joined: Tue Sep 30, 2014 11:04 am

Re: Unknown error when loading document editor.

Post by Dean » Thu Feb 25, 2016 10:37 am

Hello,

Could you please specify the exact version of Document Server you use?

Post Reply