How to force set CoAuthoring autoAssembly to true by default?

Post Reply
Murz
Posts: 1
Joined: Fri Feb 07, 2020 4:37 am

How to force set CoAuthoring autoAssembly to true by default?

Post by Murz » Mon Feb 17, 2020 6:02 am

I configure Onlyoffice server in Docker container with Seafile integration via manual: https://download.seafile.com/published/ ... _office.md and have problems with auto saving documents using default settings. Proposed solution is enable autosave (autoAssembly) at interval via editing /etc/onlyoffice/documentserver/local.json:

Code: Select all

{
   {
    "services": {
        "CoAuthoring": {
            "autoAssembly": {
                "enable": true,
                "interval": "5m"
            }
        }
    }
}
This works well, but the problem that after each restart "local.json" file is overwritten. How can I force set CoAuthoring autoAssembly values in Onlyoffice server, for work without modifying file manually at each restart?

Carl
Posts: 472
Joined: Thu Apr 12, 2018 10:00 am

Re: How to force set CoAuthoring autoAssembly to true by default?

Post by Carl » Mon Feb 17, 2020 2:14 pm

Hello,

You can create a new config file with this parameter inside the container /etc/onlyoffice/documentserver/local-production-linux.json and mount it on host:

Code: Select all

-v ./local-production-linux.json:/etc/onlyoffice/documentserver/local-production-linux.json
This way you will not lose the parameter value on container restart.

alexw
Posts: 2
Joined: Thu Jun 18, 2020 5:38 pm

Re: How to force set CoAuthoring autoAssembly to true by default?

Post by alexw » Thu Jun 18, 2020 5:46 pm

This solution does not work anymore in the current documentserver docker container.

When starting the container the following error message appears:

Code: Select all

ds:docservice: ERROR (not running)
ds:docservice: ERROR (spawn error)
ds:converter: ERROR (not running)
ds:converter: ERROR (spawn error)
it does not matter if the file is created inside the container or is mounted.

Carl
Posts: 472
Joined: Thu Apr 12, 2018 10:00 am

Re: How to force set CoAuthoring autoAssembly to true by default?

Post by Carl » Thu Jun 25, 2020 3:49 pm

Hello alexw,

Please provide the content of your local-production-linux.json file so we can check if there are any issues with its structure. Also specify the version of the Document Server you are using.

alexw
Posts: 2
Joined: Thu Jun 18, 2020 5:38 pm

Re: How to force set CoAuthoring autoAssembly to true by default?

Post by alexw » Fri Jun 26, 2020 11:17 pm

my mistake - the code pasted from post 1 of this thread has a minor mistake - it has one too many { symbols at the beginning:
Murz wrote:
Mon Feb 17, 2020 6:02 am
I configure Onlyoffice server in Docker container with Seafile integration via manual: https://download.seafile.com/published/ ... _office.md and have problems with auto saving documents using default settings. Proposed solution is enable autosave (autoAssembly) at interval via editing /etc/onlyoffice/documentserver/local.json:

Code: Select all

{
   {
    "services": {
        "CoAuthoring": {
            "autoAssembly": {
                "enable": true,
                "interval": "5m"
            }
        }
    }
}
This works well, but the problem that after each restart "local.json" file is overwritten. How can I force set CoAuthoring autoAssembly values in Onlyoffice server, for work without modifying file manually at each restart?
the correct text to paste (as it is correctly shown in the seafile document) should be:

Code: Select all

{
    "services": {
        "CoAuthoring": {
            "autoAssembly": {
                "enable": true,
                "interval": "5m"
            }
        }
    }
}

Post Reply