Fatal process OOM in Zone # Received signal 4 ILL_ILLOPN

Issues during installation, usage and configuring
Post Reply
z000ao8q
Posts: 3
Joined: Mon Jan 04, 2021 10:05 am

Fatal process OOM in Zone # Received signal 4 ILL_ILLOPN

Post by z000ao8q » Mon Jan 04, 2021 10:19 am

Hello OO Team,

thank you for your app!
I have an issue with using OO in Nextcloud - as I think it is OO related, I am posting in this forum.

Issue:
Files are not synced from OO back to Nextcloud.
When checking the logs, I can see the following error:

Code: Select all

Fatal process OOM in Zone\n#\n\nReceived signal 4 ILL_ILLOPN 7f84e0640b39\n\n==== C stack trace ===============================\n\n [0x7f84e0641d82]\n .... \n[end of stack trace]\nIllegal instruction\n"
...
CustomMessage":"Error while applying changes for document 3690362553"}

in
/homepages/4/xxxx/htdocs/nextcloud/apps/documentserver_community/lib/DocumentConverter.php
looking at the details, ist seems it is triggered by the x2t conversion if I understand this correctly.

I was digging deeper to check the param.xml, which is transferred to x2t. The failing ones looks like:

Code: Select all

<TaskQueueDataConvert xmlns:xsi=\"http://www.w3.org/2001/XMLSchema-instance\" xmlns:xsd=\"http://www.w3.org/2001/XMLSchema\">
<m_sFileFrom>/homepages/4/xxxx/htdocs/nextcloud/data/appdata_ocr9c2fblyji/documentserver_community/doc_3690362553/Editor.bin</m_sFileFrom>
<m_sFileTo>/homepages/4/xxxx/htdocs/nextcloud/data/appdata_ocr9c2fblyji/documentserver_community/doc_3690362553/saved.xlsx</m_sFileTo>
<m_nFormatTo>257</m_nFormatTo>
<m_bIsPDFA xsi:nil=\"true\"/>
<m_bFromChanges>true</m_bFromChanges>
<m_sFontDir>/homepages/4/xxxx/htdocs/nextcloud/apps/documentserver_community/3rdparty/onlyoffice/documentserver/core-fonts</m_sFontDir>
<m_sThemeDir>/homepages/4/xxxx/htdocs/nextcloud/apps/documentserver_community/3rdparty/onlyoffice/documentserver/sdkjs/slide/themes</m_sThemeDir>
<m_bIsNoBase64 xsi:nil=\"true\"/>
<m_oTimestamp>2021-01-04T09:49:14+00:00</m_oTimestamp>
</TaskQueueDataConvert>
I did another test to open a document and used the "save as" function in OO to create a new document. this is processed correctly. This one creates the following xml:

Code: Select all

<TaskQueueDataConvert xmlns:xsi=\"http://www.w3.org/2001/XMLSchema-instance\" xmlns:xsd=\"http://www.w3.org/2001/XMLSchema\">
<m_sFileFrom>/homepages/4/xxxx/htdocs/nextcloud/data/appdata_ocr9c2fblyji/documentserver_community/doc_245455602/save-download.bin</m_sFileFrom>
<m_sFileTo>/homepages/4/xxxx/htdocs/nextcloud/data/appdata_ocr9c2fblyji/documentserver_community/doc_245455602/Tabelle.xlsx</m_sFileTo>
<m_nFormatTo>257</m_nFormatTo>
<m_bIsPDFA xsi:nil=\"true\"/>
<m_bFromChanges xsi:nil=\"true\"/>
<m_sFontDir>/homepages/4/d208390625/htdocs/nextcloud/apps/documentserver_community/3rdparty/onlyoffice/documentserver/core-fonts</m_sFontDir>
<m_sThemeDir>/homepages/4/d208390625/htdocs/nextcloud/apps/documentserver_community/3rdparty/onlyoffice/documentserver/sdkjs/slide/themes</m_sThemeDir>
<m_bIsNoBase64>true</m_bIsNoBase64>
<m_oTimestamp>2021-01-04T09:54:42+00:00</m_oTimestamp>
</TaskQueueDataConvert>
I don´t know if this comparison has any meaning. Can you support me to find the possible issue, why 1. is failing and 2. is correct?


thank you for your support

Carl
Posts: 518
Joined: Thu Apr 12, 2018 10:00 am

Re: Fatal process OOM in Zone # Received signal 4 ILL_ILLOPN

Post by Carl » Tue Jan 05, 2021 11:05 am

Hello z000ao8q,

Unfortunately, we cannot assist with the Community Document Server app as it wasn't developed by us. You can post this question on Nextcloud forum.

If you install a dedicated document server and enable integration as per https://api.onlyoffice.com/editors/nextcloud, we will be glad to assist.

z000ao8q
Posts: 3
Joined: Mon Jan 04, 2021 10:05 am

Re: Fatal process OOM in Zone # Received signal 4 ILL_ILLOPN

Post by z000ao8q » Tue Jan 05, 2021 11:17 am

Hello Carl,

thank you for the reply. I know about your limited support, which I understand.

but can you judge the kind of error? is this error not thrown from OO?
I found another error report in this forum for ILL_ILLOPN also, where the issue was located in the xml. So I was expecting that this could be looked at here also.
if its an error in the NC related coding "around" the conversion, I will have to take care, for sure.
but x2t is OO, or is my understanding not correct here?

thank you for your thoughts,
any feedback is appreciated

Carl
Posts: 518
Joined: Thu Apr 12, 2018 10:00 am

Re: Fatal process OOM in Zone # Received signal 4 ILL_ILLOPN

Post by Carl » Thu Jan 14, 2021 11:14 am

Hello z000ao8q,

Sorry for the late reply.

Community Document Server app is an attempt to completely rewrite the Document Server in PHP language. I cannot say for sure what causes the described issue. If you encounter something similar when deploying the Document Server as per our guides, let me know.

Post Reply