Invalid token error when I try to connect onlyoffice with nextcloud

Issues during installation, usage and configuring
Post Reply
MrSolarius
Posts: 2
Joined: Tue Nov 12, 2019 7:03 pm

Invalid token error when I try to connect onlyoffice with nextcloud

Post by MrSolarius » Tue Nov 12, 2019 7:23 pm

Hi ;),
So I have problem, like i said on this topic title, when I try to connect my onlyoffice document server to nextcloud I have Invalid Token error.

But first, more information about my configuration:

I have an ESXI with 2 VM run on ubuntu server 18LTS.
The first VM run Nextcloud on apache server
The Second one run OnlyOffice document server directly (I mean without docker container)

On my onlyoffice VM I have install selfcertificat from openSSL to nginx.

When I try to access to onlyoffice server form a browser everything work. I have the message "Document Server Is Running". But when i try to connect from nextcloud app I have this the Invalid Token Error.

So I have try different thing but no one have work.
First I have try to just don't activate the token authentication in default.json but same error
Second I have try enable token in default.json and connect with but still same error

And because I really don't know from where this error goes, I don't have try other thing.

So I wish you can help me here :D

Andrew
Posts: 102
Joined: Mon Apr 01, 2019 1:09 pm

Re: Invalid token error when I try to connect onlyoffice with nextcloud

Post by Andrew » Wed Nov 13, 2019 7:10 am

Hello MrSolarius,

Please check JWT settings in /etc/onlyoffice/documentserver/local.json, here is example how it should look:

Code: Select all

      "token": {
        "enable": {
          "request": {
            "inbox": true,
            "outbox": true
          },
          "browser": true
        },
        "inbox": {
          "header": "Authorization"
        },
        "outbox": {
          "header": "Authorization"
        }
      },
      "secret": {
        "inbox": {
          "string": "your_secret"
        },
        "outbox": {
          "string": "your_secret"
        },
        "session": {
          "string": "your_secret"
        }
"your_secret" value should be same as in Nextcloud connector settings. If you edit local.json and want to apply changes please don't forget to restart Document Servers services

Code: Select all

supervisorctl restart all

MrSolarius
Posts: 2
Joined: Tue Nov 12, 2019 7:03 pm

Re: Invalid token error when I try to connect onlyoffice with nextcloud

Post by MrSolarius » Wed Nov 13, 2019 11:51 am

It works !!!
Really thanks :D

Post Reply