ONLYOFFICE Mail Server Timeout

Questions/problems on Docker
Alexandre
Posts: 197
Joined: Thu Dec 12, 2019 11:08 am

Re: ONLYOFFICE Mail Server Timeout

Post by Alexandre » Tue Dec 22, 2020 2:12 pm

Hello GyozaGuy.
What version of MySQL is currently installed?

GyozaGuy
Posts: 14
Joined: Tue Nov 17, 2020 4:10 am

Re: ONLYOFFICE Mail Server Timeout

Post by GyozaGuy » Tue Dec 22, 2020 4:22 pm

The MySQL version that is installed is:

Code: Select all

mysql  Ver 8.0.22-0ubuntu0.20.04.3 for Linux on x86_64 ((Ubuntu))
The service is no longer running once I realized it might be conflicting with Docker, but it is still installed.

Alexandre
Posts: 197
Joined: Thu Dec 12, 2019 11:08 am

Re: ONLYOFFICE Mail Server Timeout

Post by Alexandre » Thu Dec 24, 2020 10:52 am

Hello GyozaGuy.
No, portal needs MySQL. Could you please go to the host and execute docker ps. Please show me the result.
You mentioned earlier that you upgraded your old version of MySQL. So the portal installation was not clean? I mean a clean server and just run a script installation of the portal via bash workspace-install.sh.
If the istallation was not clean, then dependencies pf old apps could remain that conflict with the portal. If so, could you try out the installation from scratch on a clean server using this guide https://helpcenter.onlyoffice.com/insta ... ocker.aspx
One more thing. There is a strict binding to MySQL version. Docker installation should use v.5.7 only.

GyozaGuy
Posts: 14
Joined: Tue Nov 17, 2020 4:10 am

Re: ONLYOFFICE Mail Server Timeout

Post by GyozaGuy » Mon Dec 28, 2020 6:43 am

This is the output of "docker ps":

Code: Select all

CONTAINER ID   IMAGE                                    COMMAND                  CREATED       STATUS       PORTS                                                                                                                                                                                        NAMES
1f385c8db341   onlyoffice/mailserver:1.6.75             "/bin/sh -c 'export …"   10 days ago   Up 10 days   0.0.0.0:25->25/tcp, 0.0.0.0:143->143/tcp, 0.0.0.0:465->465/tcp, 0.0.0.0:587->587/tcp, 0.0.0.0:993->993/tcp, 0.0.0.0:995->995/tcp, 0.0.0.0:4190->4190/tcp, 0.0.0.0:8081->8081/tcp, 3306/tcp   onlyoffice-mail-server
b31e7a99141d   onlyoffice/communityserver:11.0.1.1482   "/app/run-community-…"   2 weeks ago   Up 10 days   0.0.0.0:443->443/tcp, 3306/tcp, 5280/tcp, 9865-9866/tcp, 9871/tcp, 9882/tcp, 0.0.0.0:5222->5222/tcp, 9888/tcp, 0.0.0.0:8080->80/tcp                                                          onlyoffice-community-server
68b808b24645   onlyoffice/controlpanel:2.9.1.369        "/var/www/onlyoffice…"   2 weeks ago   Up 10 days   80/tcp, 443/tcp, 9833-9834/tcp                                                                                                                                                               onlyoffice-control-panel
b5f26501488c   onlyoffice/documentserver:6.1.0.83       "/app/ds/run-documen…"   2 weeks ago   Up 10 days   80/tcp, 443/tcp                                                                                                                                                                              onlyoffice-document-server
acfb69f206a9   mysql:5.7.30                             "docker-entrypoint.s…"   2 weeks ago   Up 10 days   3306/tcp, 33060/tcp                                                                                                                                                                          onlyoffice-mysql-server
Also I didn't upgrade an old version of MySQL, what I meant was that I already had a non-Docker version of MySQL installed. The server I ran "workspace-install.sh" on was not clean because I don't have a clean device available, but I've done my best to make sure nothing is running that would conflict with ONLYOFFICE. That MySQL server instance is the only thing I can think of that might conflict. Sorry about the confusion!

Alexandre
Posts: 197
Joined: Thu Dec 12, 2019 11:08 am

Re: ONLYOFFICE Mail Server Timeout

Post by Alexandre » Tue Dec 29, 2020 12:21 pm

Hello GyozaGuy.
Probably you need to try a clean installation.We recommend to install ONLYOFFICE on "clean" server to avoid dependency and port conflicts.
Even if the old apps are removed or stopped, the remaining dependencies may conflict with the portal.

GyozaGuy
Posts: 14
Joined: Tue Nov 17, 2020 4:10 am

Re: ONLYOFFICE Mail Server Timeout

Post by GyozaGuy » Wed Jan 13, 2021 1:33 am

I haven't been able to try on a clean device still, but maybe I found something. The server doesn't give me any errors but won't send or receive anything (not even messages about failure to send/receive). In the logs though I see messages like these when trying to send messages:

Code: Select all

Jan 13 01:22:52 mail postfix/qmgr[328]: 06D191A06BA: from=<admin@gyozaguy.com>, size=1470, nrcpt=1 (queue active)
Jan 13 01:22:52 mail postfix/qmgr[328]: 31B7F1A06B5: from=<steven@gyozaguy.com>, size=1477, nrcpt=1 (queue active)
Jan 13 01:22:52 mail postfix/qmgr[328]: CAD471A06BF: from=<steven@gyozaguy.com>, size=1456, nrcpt=1 (queue active)
Jan 13 01:22:52 mail postfix/pipe[96071]: 06D191A06BA: to=<steven@gyozaguy.com>, relay=dovecot, delay=1110, delays=1110/0.04/0/0.04, dsn=4.3.0, status=deferred (temporary failure. Command output: Can't open log file /var/log/dovecot-sieve.log: Permission denied )
Jan 13 01:22:52 mail postfix/pipe[96072]: 31B7F1A06B5: to=<steven@gyozaguy.com>, relay=dovecot, delay=1200, delays=1200/0.02/0/0.04, dsn=4.3.0, status=deferred (temporary failure. Command output: Can't open log file /var/log/dovecot-sieve.log: Permission denied )
Jan 13 01:22:52 mail postfix/pipe[96074]: CAD471A06BF: to=<admin@gyozaguy.com>, relay=dovecot, delay=1100, delays=1100/0.03/0/0.04, dsn=4.3.0, status=deferred (temporary failure. Command output: Can't open log file /var/log/dovecot-sieve.log: Permission denied )
Could it just be some permissions issue preventing the messages from sending?

Alexandre
Posts: 197
Joined: Thu Dec 12, 2019 11:08 am

Re: ONLYOFFICE Mail Server Timeout

Post by Alexandre » Mon Jan 18, 2021 2:10 pm

Could it just be some permissions issue preventing the messages from sending?
Let's try to check it out.
Please go to Mail server container and run chmod 777 -R /var/log/
Check if the situation has improved.

GyozaGuy
Posts: 14
Joined: Tue Nov 17, 2020 4:10 am

Re: ONLYOFFICE Mail Server Timeout

Post by GyozaGuy » Wed Jan 20, 2021 5:03 am

That immediately fixed sending messages between accounts at the custom domain, so we've made progress! Now I'm getting connection timeout errors when trying to send an e-mail to an external (Gmail) address:

Code: Select all

Jan 20 04:38:35 mail postfix/qmgr[328]: E14611A06E4: from=<admin@gyozaguy.com>, size=1329, nrcpt=1 (queue active)
Jan 20 04:39:05 mail postfix/smtp[313794]: connect to gmail-smtp-in.l.google.com[172.253.114.27]:25: Connection timed out
Jan 20 04:39:36 mail postfix/smtp[313794]: connect to alt1.gmail-smtp-in.l.google.com[142.250.96.27]:25: Connection timed out 
Jan 20 04:40:06 mail postfix/smtp[313794]: connect to alt2.gmail-smtp-in.l.google.com[64.233.177.27]:25: Connection timed out
Jan 20 04:40:36 mail postfix/smtp[313794]: connect to alt3.gmail-smtp-in.l.google.com[142.250.123.27]:25: Connection timed out
Jan 20 04:41:06 mail postfix/smtp[313794]: connect to alt4.gmail-smtp-in.l.google.com[173.194.68.27]:25: Connection timed out
Jan 20 04:41:06 mail postfix/smtp[313794]: E14611A06E4: to=<redacted@gmail.com>, relay=none, delay=810, delays=660/0.04/150/0, dsn=4.4.1, status=deferred (connect to alt4.gmail-smtp-in.l.google.com[173.194.68.27]:25: Connection timed out)
I've tried pinging both the Google domains and IPs from both my server and from within the Docker container, and it always succeeds, so it seems at least DNS is working.

Alexandre
Posts: 197
Joined: Thu Dec 12, 2019 11:08 am

Re: ONLYOFFICE Mail Server Timeout

Post by Alexandre » Fri Jan 22, 2021 3:02 pm

Could you please check your firewall and outgoing ports. Probably something is blocking outgoing port 25.
Also, please run telnet alt4.gmail-smtp-in.l.google.com 25 and show me the result.

GyozaGuy
Posts: 14
Joined: Tue Nov 17, 2020 4:10 am

Re: ONLYOFFICE Mail Server Timeout

Post by GyozaGuy » Fri Jan 22, 2021 9:34 pm

Here is the output:

Code: Select all

telnet alt4.gmail-smtp-in.l.google.com 25
Trying 173.194.175.26...
Trying 2607:f8b0:400c:c12::1a...
telnet: Unable to connect to remote host: Network is unreachable
Just to be sure, I ran this same command on three separate devices, including a device I put outside my firewall entirely, but the result was always the same. Are we sure Google allows a telnet connection this way? At this point it's looking like if it is blocked, it may be at my ISP level, and if that's the case there's probably nothing I can do to get this working.

I use UFW on the device running the mail server, and by default it allows everything out so I've never had to open outgoing ports before, but just to be sure I added the following rule:

Code: Select all

To                         Action      From
--                         ------      ----
25/tcp                     ALLOW OUT   Anywhere
This didn't make a difference though.

Thanks again for all of your help!

Post Reply