Page 1 of 1

Need to upgrade OnlyOffice for Nextcloud 14

Posted: Mon Dec 31, 2018 3:04 pm
by NoMax
Hello,

I just ran the script install to update Nextcloud from V 13 to V 14. However, after updating OnlyOffice no longer functions, and my only option is to Uninstall. I see the following error message in my Nextcloud apps: "This app cannot be installed because the following dependencies are not fulfilled:
Server version 13 or lower is required."

I have OnlyOffice installed in a Docker container. Nextcloud and OnlyOffice are running on the same server. Unfortunately I don't know how to complete the upgrade to get OnlyOffice working again. There is no option to upgrade from within Nextcloud Apps, only Delete is available.

Where can I find complete instructions on how to complete this update?

Thank you.

Re: Need to upgrade OnlyOffice for Nextcloud 14

Posted: Wed Jan 09, 2019 9:47 am
by Carl
Hello,

Please specify the version of Document Server you are currently using. In order to update the Document Server container, you need to simply stop the existing container and then run a new one:
https://helpcenter.onlyoffice.com/serve ... ation.aspx
Also make sure you have the required connector version installed (https://apps.nextcloud.com/apps/onlyoffice). For Nextcloud v14 you need to have connector app 2.1.2.
There is no option to upgrade from within Nextcloud Apps, only Delete is available
Usually the connector app can be upgraded within Nextcloud interface. Please make a screenshot of the app list in Nextcloud where ONLYOFFICE app can be seen.

Re: Need to upgrade OnlyOffice for Nextcloud 14

Posted: Mon Jan 14, 2019 7:26 pm
by NoMax
Hello,

It looks like I'm running version 1.2.0.

I have attached the screenshot. Please note I have reverted back to Nextcloud 13.

Thanks in advance for any assistance.

NM

Re: Need to upgrade OnlyOffice for Nextcloud 14

Posted: Wed Jan 16, 2019 1:07 pm
by Carl
Hello,

In this case I'd recommend to remove the current connector (click Disable => Remove option will appear) and then install the new version in the Nextcloud store.