onlyofficeDocumens -nextcloud - Docker Container ipv6 errors

Questions/problems on Docker
Post Reply
Posts: 1
Joined: Fri Feb 23, 2018 1:41 pm

onlyofficeDocumens -nextcloud - Docker Container ipv6 errors

Post by technik » Fri Feb 23, 2018 1:59 pm

we are running nextcloud v13 all updates on an debian 8 with Apache 2.4 and disabled ipv6 in the sysctl.conf
Server is in a DMZ, Port 80 and 443 are connected by NAT.
So far everything works fine.

Than we installed docker and run the onlyoffice container with http on Port 8080 (no 443) and we followed this manual: ... proxy.aspx
-> With option 3, Virtual path.
The Integration with onlyoffice was working fine, everything good. We saw same IPV6 errors in the home/onlyoffice/DocumentServer/logs/documentserver/nginx.error.log, but we didn't care - it was working.

A few days later we got a report - onlyoffice is loading and loading and loading( circling), but not working. We called to the homepage in a browser -onlyoffice is working.
We restarted the docker container and nextcloud was again working.
1 day later - again onlyoffice website was browsable, but nextcloud couldn't connect to it.

We tried and tested but no result.

No we gave the server a second IP, binded the nextcloud apache to the 1st Ip and started the container on port 80 and 443 exlusivly on the second ip. ( Yes we fetched some letsencrypt certificates and put them in de folder /app/onlyoffice/DocumentServer/data/certs/ -> and of cource the started the container with the -v option to mound them.
Onlyoffice was reachable

docker run --name onlyoffice -it --restart always -p <IP>80:80 -p <IP>:443:443 -v /home/onlyoffice/DocumentServer/logs:/var/log/onlyoffice -v /app/onlyoffice/DocumentServer/data:/var/www/onlyoffice/Data onlyoffice/documentserver

Current situation
Debian Server
IP1: Apache 2.4 with nextcloud
IP2: Docker with onlyoffice Ports 80 and 443

It was working again *jippieh* - but stop, 12hours later the onlyoffice had the same error.
The circle is running but no document can be edited. After some tries to disable IPv6 in the Container without any success I'am writing this post.

We have a lot of this errors in the nginx.log

2018/02/23 13:38:21 [error] 453#0: *16 connect() to [::1]:8000 failed (101: Network is unreachable) while connecting to upstream, client: 10.41.XXXXXX, server: , request: "POST /coauthoring/CommandService.ashx HTTP/1.0", upstream: "http://[::1]:8000/coauthoring/CommandService.ashx", host: "onlyoffice.xxxxxxx.xx"

Had anyone similar problems - or better has anyone a working solution for us?

best regards

Posts: 1853
Joined: Tue Oct 11, 2016 2:34 pm

Re: onlyofficeDocumens -nextcloud - Docker Container ipv6 er

Post by Maxim » Fri May 11, 2018 2:25 pm

Here you will find ONLYOFFICE Document Server example configurations for proxy, maybe it will help you.

Post Reply