Cannot send or receive emails

Questions/problems on Docker
Post Reply
jpcuk
Posts: 3
Joined: Wed Feb 06, 2019 12:59 pm

Cannot send or receive emails

Post by jpcuk » Wed Feb 06, 2019 1:13 pm

Hi,

I Installed the community, mail and document servers onto a VM running docker using opensource-install.sh.

I had some permission issues with the mysql server (container kept restarting) that got resolved by changing the permissions on /app/onlyoffice/mysql/* to named:docker.

However, I am now running into issues getting mail flow working.

If I try to send an email from an activated account, I get the following bounce-back:

Reason: "AuthenticationInvalidCredentials: Incorrect authentication data"

Likewise, emails never get received but the following permission issues are present in the mail server logs (real domain name replaced with "domain"):

maillog:
Feb 6 12:05:49 domain postfix/pipe[32266]: D03F12E00CF: to=<root@domain.co.za>, relay=dovecot, delay=13441, delays=13436/0.02/0/4.6, dsn=4.3.0, status=deferred (temporary failure. Command output: Can't open log file /var/log/dovecot-sieve.log: Permission denied )

dovecot.log:
Feb 06 10:35:50 lmtp: Fatal: master: service(lmtp): child 30010 returned error 80 (Can't open log file)

Permissions on all of the dovecot log files are as default - vmail:vmail (or 2000:2000 as it appears from the docker host).

I have tried different user and group owners for the dovecot log files and restarting the postfix & dovecot processes and also restarting the mail server container but nothing so far has helped.

Any suggestions?

Thanks,

Pierre

jpcuk
Posts: 3
Joined: Wed Feb 06, 2019 12:59 pm

Re: Cannot send or receive emails

Post by jpcuk » Fri Feb 08, 2019 5:31 am

Hi,

Just an update on this issue - I removed and re-installed via docker and set a full hostname + domain name rather than just domain for the mail server and that resolved the sending email issue.

The receiving of emails still remains an issue - I can see them come in via postfix in the maillog but then the same permissions issue with dovecot-sieve.log gets logged and the mail is never delivered.

I am not convinced it's actually file permissions on the dovecot-sieve.log and dovecot-lmtp.log files as setting them to 777 doesn't fix anything or any combination of UID & GID that I've applied to those files so far.


Cheers,

Pierre

Maxim
Posts: 1945
Joined: Tue Oct 11, 2016 2:34 pm

Re: Cannot send or receive emails

Post by Maxim » Mon Feb 11, 2019 7:51 am

Hello jpcuk!
Did you install using script?

jpcuk
Posts: 3
Joined: Wed Feb 06, 2019 12:59 pm

Re: Cannot send or receive emails

Post by jpcuk » Mon Feb 11, 2019 11:38 am

Hi Maxim,

Yes, I used the install script (it ran through successfully) but there were the permissions issues with the mysql container data directories initially that needed correcting as described before restarting the other containers and getting everything to run.


Pierre

Post Reply