Document Editor deleted all of metadata on import Images

Suggestions on Document Server Installation/Functionality
Post Reply
djk81
Posts: 2
Joined: Tue Mar 05, 2019 8:28 am

Document Editor deleted all of metadata on import Images

Post by djk81 » Mon Apr 22, 2019 9:20 am

Hello. we'are using onlyoffice's document server to service our customer.

We have some images (jpeg, png) and I added some extra bytes on that. ("exif" on jpeg, "chunk" on png)


it looks like below.

png => {'dpi': '(96, 96)', 'gamma': '0.45455', 'Creation Time': '1601:04:30 15:14:35', 'CUSTOM': 'BUPTLE_STAMP', 'srgb': '0'}
jpeg => {'Author' : 'BUPTLE_STAMP'}


then, we replace that images to company stamp image on the end of biz process.
it works fine.

but i realized it did not work when I copy and paste that images in docx file to document editor or document editor to docx file.
Document editor clean up my metadata on images when copy and paste to extra App(like ms-word).

if the customer do copy original image file and paste document editor (or drag and drop) is fine.

but our customer is doing like this.
1. open the docx file by ms word office.
2. then they did ctrl+c on image files. (or drag and drop) then copied to document editor.
3. then onlyoffice's Document editor cleaned up on that data in images.

How can i fix this. or is there any config on do not deleted any metadata on images on copy-paste through from external application?

thanks. and sorry for my english. im not native on eng.

Carl
Posts: 160
Joined: Thu Apr 12, 2018 10:00 am

Re: Document Editor deleted all of metadata on import Images

Post by Carl » Fri Apr 26, 2019 12:22 pm

Hello,

I have replied to your request in our Helpdesk.

Post Reply