Community Server: Error uploading a file

Suggestions on Community Server Installation/Functionality
Post Reply
dupcliate_hank
Posts: 4
Joined: Thu Jan 17, 2019 3:29 pm

Community Server: Error uploading a file

Post by dupcliate_hank » Thu Jan 17, 2019 4:24 pm

Hello,

i´ve got a problem and hope, that someone can help.

I´m using the following onlyoffic docker-containers (community-server, document-server, mysql-server) and i´m very pleased about the functionality.
All works fine for me (shared folders, databases, etc.) but i found out, that uploads from outside won´t work. The error-message appears without error-code or hints.
Image
But in the screen you can see, that it´s possible to create files or move files from e-mail attachments.

Is it a bug or maybee a misconfiguration?

Thanks.

Maxim
Posts: 1902
Joined: Tue Oct 11, 2016 2:34 pm

Re: Community Server: Error uploading a file

Post by Maxim » Fri Jan 18, 2019 12:55 pm

Hello dupcliate_hank!
Is there a proxy server before Onlyoffice server? Maybe problem in your network.
You should take a look at logs (/app/onlyoffice/CommunityServer/log). There must be errors.

dupcliate_hank
Posts: 4
Joined: Thu Jan 17, 2019 3:29 pm

Re: Community Server: Error uploading a file

Post by dupcliate_hank » Fri Jan 18, 2019 4:34 pm

Hi Maxim,

yes in deed, community-server is working as a virtual host, behind a apache-proxy. The docker-container ist bridged (192.168.0.212),

I added the following lines in the conf of the virtual host, to redirect the traffic to my internal net. That´s the config for community-server. I did it close to the document-server´s config.

SetEnvIf Host "^(.*)$" THE_HOST=$1
RequestHeader setifempty X-Forwarded-Proto https
RequestHeader setifempty X-Forwarded-Host %{THE_HOST}e
ProxyAddHeaders Off

ProxyPassMatch (.*)(\/websocket)$ "ws://192.168.0.212:80/$1$2"
ProxyPass / "http://192.168.0.212:80/"
ProxyPassReverse / "http://192.168.0.212:80/"

Excuse me, but i´m new in docker. I mounted the following directory to a share (/var/log/onlyoffice). I guess, that´s not the place i shoud look?

Thanks,

d_h

dupcliate_hank
Posts: 4
Joined: Thu Jan 17, 2019 3:29 pm

Re: Community Server: Error uploading a file

Post by dupcliate_hank » Fri Jan 18, 2019 6:05 pm

Ok, meanwhile that´s i found out .

The error occurs only, when I try to upload a file calling the Communityserver-portal via https (SSL from outside). But the upload worked after calling the portal via http. Hmmmh!

However i didn´t found an error in the logs (there is no path /app/onlyoffice/CommunityServer/log) in the container and i looked instead in the mounted "/var/log/onlyoffice" folder in such files like web.files.log etc..

Maxim
Posts: 1902
Joined: Tue Oct 11, 2016 2:34 pm

Re: Community Server: Error uploading a file

Post by Maxim » Mon Jan 21, 2019 6:54 am

Hello dupcliate_hank!
1. How did you enable HTTPS? What instruction you followed?
2. 443 port should be open for SSL certs.
3. Is your portal available from extern? If yes please use SSL checker to check your SSL certs.

dupcliate_hank
Posts: 4
Joined: Thu Jan 17, 2019 3:29 pm

Re: Community Server: Error uploading a file

Post by dupcliate_hank » Mon Jan 21, 2019 2:51 pm

Hi Maxim,

now it´s working, thanks.

The SSL-certificates were on the proxy. Now they´re in the docker-container and the problem is solved.
Very, very nice but i´ve got two wishes:

1.) Disk-Quotas for users
2.) Getting rid of the limitation of 20 users :-)

Cheers,
hank

Post Reply