Missing allfonts.js

Issues during installation and related to database
Post Reply
sbeaver
Posts: 6
Joined: Fri Mar 10, 2017 10:04 pm

Missing allfonts.js

Post by sbeaver » Sat Mar 11, 2017 4:24 am

Further to my earlier post about document server stalling at the "Loading" message, I have discovered an error message:

2017/03/10 22:04:25 [error] 2626#2626: *92 open() "/var/www/onlyoffice/documentserver/sdkjs/common/AllFonts.js" failed (2: No such file or directory), client: 172.21.2.11, server: , request: "GET /2017-02-17-15-53/sdkjs/common/AllFonts.js HTTP/1.1", host: "onlyoffice-ds.test.com", referrer: "http://onlyoffice-ds.test.com/2017-02-1 ... rameEditor"

In my nginx logs. The file AllFonts.js is not present on the document server.

Maxim
Posts: 1949
Joined: Tue Oct 11, 2016 2:34 pm

Re: Missing allfonts.js

Post by Maxim » Mon Mar 13, 2017 9:41 am

Hello sbeaver!
It's not good. You should check your permissions, iptables or firewalls.

sbeaver
Posts: 6
Joined: Fri Mar 10, 2017 10:04 pm

Re: Missing allfonts.js

Post by sbeaver » Mon Mar 13, 2017 1:59 pm

No firewall is in place, and the permissions are correctly set.

I was able to visit the public document server at https://doc.onlyoffice.com/welcome/, make a copy of the AllFOnts.js file on that site and copy it to my document server. My OnlyOffice installation now works correctly.

I assume that AllFont/js was not being generated during the installation process or is missing from the installer package

Maxim
Posts: 1949
Joined: Tue Oct 11, 2016 2:34 pm

Re: Missing allfonts.js

Post by Maxim » Tue Mar 14, 2017 6:21 am

Hello sbeaver!
I suppose this issue is solved now. Document Server works correctly. I'm glad to hear it.

sbeaver
Posts: 6
Joined: Fri Mar 10, 2017 10:04 pm

Re: Missing allfonts.js

Post by sbeaver » Tue Mar 14, 2017 12:24 pm

NO

On a fresh install, the file AllFont.js is missing from Document server. Would you please explain how this file is generated and why it is not present in the current installer version?

Maxim
Posts: 1949
Joined: Tue Oct 11, 2016 2:34 pm

Re: Missing allfonts.js

Post by Maxim » Tue Mar 14, 2017 1:40 pm

Please specify what instruction did you use to install? This one?

sbeaver
Posts: 6
Joined: Fri Mar 10, 2017 10:04 pm

Re: Missing allfonts.js

Post by sbeaver » Tue Mar 14, 2017 8:09 pm


Maxim
Posts: 1949
Joined: Tue Oct 11, 2016 2:34 pm

Re: Missing allfonts.js

Post by Maxim » Wed Mar 15, 2017 7:32 am

Hello sbeaver!
Please send us logs /var/log/onlyoffice/documentserver.
support@onlyoffice.com with link to your post in subject or attach archive to your post here.
Maybe there is a font in your system which causes errors of OO installation.

sebastien
Posts: 9
Joined: Mon Mar 12, 2018 8:59 pm

Re: Missing allfonts.js

Post by sebastien » Mon Mar 12, 2018 9:40 pm

I did have an issue with this missing file too.

** config **

Both services run on two separate Debian 9.3 VMs:

- VM1: Nextcloud v13.0 + Only Office 1.2.0 plugin
- VM2: OnlyOffice Document Server v5.0.7

** description **

Nextcloud then behaves like this:

- clicking the "save" button in the plugin configuration section says: "ok, config have been successfully saved" :)
but
- clicking onto a docx file would run OnlyOffice (you can see the animated logo) and then would finish in timeout :(

** what's wrong **

- taking a look to the nginx log file on the OO machine, you can see this:

root@office# tail -f /var/log/onlyoffice/documentserver/nginx.error.log
2018/03/09 12:07:56 [error] 7768#7768: *581 open() "/var/www/onlyoffice/documentserver/sdkjs/common/AllFonts.js" failed (2: No such file or directory)

- root@office# ls /var/www/onlyoffice/documentserver/sdkjs/common/AllFonts.js
'/var/www/onlyoffice/documentserver/sdkjs/common/AllFonts.js': No such file or directory

** fixing **

#-- we'll need sudo command which is not installed by default on Debian9; let's install it
root@office# apt install sudo

#-- don't know if you really need to shutdown nginx; no big deal, let's work in good conditions
root@office# service nginx stop

#-- then run the "documentserver-generate-allfonts.sh" script
root@office# bash /usr/bin/documentserver-generate-allfonts.sh
Generating AllFonts.js, please wait...Done
onlyoffice-documentserver:docservice: stopped
onlyoffice-documentserver:docservice: started
onlyoffice-documentserver:converter: stopped
onlyoffice-documentserver:converter: started
...

** checking **
root@office# ls /var/www/onlyoffice/documentserver/sdkjs/common/AllFonts.js
/var/www/onlyoffice/documentserver/sdkjs/common/AllFonts.js

ok, cool. Now we do have the required AllFonts.js file

:)

** enjoy **

#-- restart nginx if you wish
root@office# service nginx restart

:)
Great ! now OnlyOffice works just fine for me (and this app is really nice I must admit)

Maxim
Posts: 1949
Joined: Tue Oct 11, 2016 2:34 pm

Re: Missing allfonts.js

Post by Maxim » Fri Mar 16, 2018 10:35 am

Hello sebastien!
Great!!!! :D

Post Reply