CentOS install fails with "Requires: mysql-server"

Issues during installation and related to database
Post Reply
jack
Posts: 2
Joined: Wed Dec 14, 2016 11:32 pm

CentOS install fails with "Requires: mysql-server"

Post by jack » Thu Dec 15, 2016 12:33 am

Hi, I'm running CentOS 7 and trying to install your software.

"Error: Package: onlyoffice-communityserver-8.9.2-4.noarch (onlyoffice)
Requires: mysql-server"

While I know your instructions suggest adding a repo to install mysql, I already have mariadb and my understanding is that it "provides" mysql-server virtually: https://bugzilla.redhat.com/show_bug.cgi?id=981116

According to this bug report, these errors should be reported to the package support venue: https://bugs.centos.org/view.php?id=7586

Is there a way to resolve this?

John
Posts: 15
Joined: Wed Oct 26, 2016 1:40 pm

Re: CentOS install fails with "Requires: mysql-server"

Post by John » Fri Dec 16, 2016 1:36 pm

Hello! Please give us more information.
What instruction do you use?
At what step do you receive this error?
What is your mariadb version? Is it used for ONLYOFFICE or for something else?
We highly recommend to perform installation on a clean operating system.
Also check if your server configuration corresponds to system requirements.
Thank you for the interest in our product.

jack
Posts: 2
Joined: Wed Dec 14, 2016 11:32 pm

Re: CentOS install fails with "Requires: mysql-server"

Post by jack » Mon Dec 19, 2016 5:58 pm

Hi,
I'm using these instructions: http://helpcenter.onlyoffice.com/server ... ation.aspx

I did not add the repositories for nginx, mysql, or redis, as the main CentOS repository has the required versions of those programs. Out of curiosity, why do you suggest adding third-party repos for those packages?

The installation fails when I run "yum install onlyoffice-communityserver".

It's on a shared box right now. I'm going to try a couple things; if that doesn't work I'll try to put it on a fresh machine and follow the instructions exactly.

Maxim
Posts: 1790
Joined: Tue Oct 11, 2016 2:34 pm

Re: CentOS install fails with "Requires: mysql-server"

Post by Maxim » Tue Dec 20, 2016 7:46 am

jack wrote:Hi, I did not add the repositories for nginx, mysql, or redis, as the main CentOS repository has the required versions of those programs. Out of curiosity, why do you suggest adding third-party repos for those packages?
Because first of all the instructions are official and up-to-date, second very often there are no necessary repos on VPS or VDS (CentOS is minimal on servers)
Let me recommend to you to use Ubuntu on server with OnlyOffice Docker installation.

Post Reply