Page 1 of 1

ERROR: Sorry, portal is on maintenance. It may take some time.

Posted: Mon Apr 15, 2019 6:50 pm
by normann
Hi there,

I'm facing this kind of error - if the screen does not work it's:
Sorry, portal is on maintenance. It may take some time.
Image

It's Community Edition installed on WinSrv2016.

It was working for about a month and than out of sudden i'm getting this error for about a week.

Cannot find the reason. Any ideas ?

Re: ERROR: Sorry, portal is on maintenance. It may take some time.

Posted: Tue Apr 16, 2019 7:55 am
by normann
To prevent missguided advices:
- server was restarted
- OnlyOffice was deinstalled and reinstalled
- all prerequisites were deinstalled and reinstalled
- all OnlyOffice services are running

If I were to shoot - I'd shoot it's something with MySQL DB - but how to check if DB is connected properly ?

Re: ERROR: Sorry, portal is on maintenance. It may take some time.

Posted: Fri Apr 19, 2019 7:43 am
by Carl
Hello,

Please check the community server logs:
C:\Program Files (x86)\Ascensio System SIA\CommunityServer\Logs

If there are issues with connection to MySQL, they should be logged in web.log.

Re: ERROR: Sorry, portal is on maintenance. It may take some time.

Posted: Fri Apr 19, 2019 8:59 am
by normann
Actually I'm facing another problem. When trying to reinstall (to get some logs) I'm getting error while OnlyOffice tries to configurate RabbitMQ:
Image

Did not change any default setting.

Re: ERROR: Sorry, portal is on maintenance. It may take some time.

Posted: Fri Apr 19, 2019 11:31 am
by normann
OK I've delt with RabbitMQ.

After reinstallation (another one) the problem remains: Sorry, portal is on maintenance. It may take some time.

The log file You figured is empty (as most of them). The only log file which is suggesting anything is svcSocketIO.04-19 and there are some errors:
2019-04-19 13:04:01,880 ERROR [45] ASC - Auth error
2019-04-19 13:04:30,889 ERROR [48] ASC - Auth error
2019-04-19 13:04:59,895 ERROR [48] ASC - Auth error
2019-04-19 13:05:30,904 ERROR [53] ASC - Auth error
2019-04-19 13:06:00,907 ERROR [56] ASC - Auth error
2019-04-19 13:06:29,927 ERROR [56] ASC - Auth error
2019-04-19 13:07:00,927 ERROR [51] ASC - Auth error
2019-04-19 13:07:30,926 ERROR [47] ASC - Auth error
2019-04-19 13:07:59,954 ERROR [47] ASC - Auth error
2019-04-19 13:08:30,981 ERROR [41] ASC - Auth error
2019-04-19 13:09:00,983 ERROR [39] ASC - Auth error
2019-04-19 13:09:29,983 ERROR [39] ASC - Auth error
2019-04-19 13:10:01,005 ERROR [31] ASC - Auth error
2019-04-19 13:10:31,017 ERROR [28] ASC - Auth error
2019-04-19 13:11:00,025 ERROR [28] ASC - Auth error
2019-04-19 13:11:31,048 ERROR [23] ASC - Auth error
2019-04-19 13:12:01,051 ERROR [19] ASC - Auth error
2019-04-19 13:12:30,050 ERROR [19] ASC - Auth error
2019-04-19 13:13:01,081 ERROR [14] ASC - Auth error
2019-04-19 13:13:31,101 ERROR [12] ASC - Auth error
2019-04-19 13:14:00,089 ERROR [12] ASC - Auth error
2019-04-19 13:14:31,096 ERROR [4] ASC - Auth error
2019-04-19 13:15:01,123 ERROR [58] ASC - Auth error
2019-04-19 13:15:30,127 ERROR [58] ASC - Auth error
2019-04-19 13:16:01,165 ERROR [63] ASC - Auth error
2019-04-19 13:16:31,175 ERROR [66] ASC - Auth error
2019-04-19 13:17:00,154 ERROR [66] ASC - Auth error
2019-04-19 13:17:31,182 ERROR [71] ASC - Auth error
2019-04-19 13:18:01,215 ERROR [74] ASC - Auth error
2019-04-19 13:18:30,214 ERROR [74] ASC - Auth error
2019-04-19 13:19:01,241 ERROR [79] ASC - Auth error
2019-04-19 13:19:31,234 ERROR [81] ASC - Auth error
2019-04-19 13:20:00,246 ERROR [81] ASC - Auth error
2019-04-19 13:20:31,271 ERROR [85] ASC - Auth error
2019-04-19 13:21:01,259 ERROR [20] ASC - Auth error
2019-04-19 13:21:30,256 ERROR [20] ASC - Auth error
2019-04-19 13:22:01,287 ERROR [24] ASC - Auth error
2019-04-19 13:22:31,310 ERROR [28] ASC - Auth error
2019-04-19 13:23:00,299 ERROR [28] ASC - Auth error
2019-04-19 13:23:31,305 ERROR [35] ASC - Auth error
2019-04-19 13:24:01,321 ERROR [40] ASC - Auth error
2019-04-19 13:24:30,336 ERROR [40] ASC - Auth error
2019-04-19 13:25:01,350 ERROR [46] ASC - Auth error

Re: ERROR: Sorry, portal is on maintenance. It may take some time.

Posted: Mon Apr 22, 2019 6:45 am
by Carl
Hello,

Have you done anything on the server before the issue occurred (like OS update or ONLYOFFICE components update etc)?

Please try restarting ONLYOFFICE site in IIS. Also check if MySQL service is running in Windows Services. I would also recommend enabling extended logging in C:\Program Files (x86)\Ascensio System SIA\CommunityServer\WebStudio\web.log4net.config =>

Code: Select all

  <logger name="ASC">
    <appender-ref ref="File" />
    <level value="WARN" />
  </logger>
  <logger name="ASC.Files" additivity="false">
    <appender-ref ref="Files" />
    <level value="WARN" />
  </logger>
  <logger name="ASC.SQL" additivity="false">
    <appender-ref ref="Sql" />
    <level value="OFF" />
  </logger>
  <logger name="ASC.Api" additivity="false">
    <appender-ref ref="Api" />
    <level value="WARN" />
=> replace all values with ALL in this section => restart ONLYOFFICE site in IIS => try opening the portal anew and check the logs.

Re: ERROR: Sorry, portal is on maintenance. It may take some time.

Posted: Sun Apr 28, 2019 2:42 pm
by normann
Restarting IIS does not make any change (i've done that a dozen of times earlier). After switching LOG values to ALL almost nothing did change at all. The only new "log" is web.sql and it gives sth like:
2019-04-28 14:36:17,030|24|0,4724|Connection.Open||
2019-04-28 14:36:17,030|24|0,5926|Command.ExecuteReader|select t.id, t.alias, t.mappeddomain, t.version, t.version_changed, t.name, t.language, t.timezone, t.owner_id, t.trusteddomains, t.trusteddomainsenabled, t.creationdatetime, t.status, t.statuschanged, t.payment_id, t.last_modified, p.partner_id, p.affiliate_id, t.industry, t.spam, t.calls from tenants_tenants t left outer join tenants_partners p on t.id = p.tenant_id where alias = @p0 or mappeddomain = @p1|@p0=localhost, @p1=localhost
2019-04-28 14:36:17,046|24|8,3026|Command.ExecuteReader|select u.id, u.username, u.firstname, u.lastname, u.sex, u.bithdate, u.status, u.title, u.workfromdate, u.terminateddate, u.contacts, u.email, u.location, u.notes, u.removed, u.last_modified, u.tenant, u.activation_status, u.culture, u.phone, u.phone_activation, u.sid, u.sso_name_id, u.sso_session_id, u.create_on from core_user u where last_modified >= @p0|@p0=28.04.2019 14:31:41
2019-04-28 14:36:17,046|24|0,7943|Command.ExecuteReader|select id, name, parentid, categoryid, removed, last_modified, tenant, sid from core_group where last_modified >= @p0|@p0=28.04.2019 14:31:41
2019-04-28 14:36:17,046|24|0,4918|Command.ExecuteReader|select userid, groupid, ref_type, removed, last_modified, tenant from core_usergroup where last_modified >= @p0|@p0=28.04.2019 14:31:41
2019-04-28 14:36:17,062|24|0.029|Connection.Dispose||
2019-04-28 14:36:17,062|24|0.0009|Connection.Dispose||
The thing I did and which might have caused all this situation is that WinSrv had WSUS role which I did delete. WSUS runs with it's own database but it's MsSQL. Logically - I do not see any connection... on the other hand - I do not see any other connection that this.

EDIT:

Can You provide me with the list of all WinSrv prerequisites to run CommunityServer ? Maybe deleting WSUS role did delete some of the IIS or other WinSrv prerequisites...

Re: ERROR: Sorry, portal is on maintenance. It may take some time.

Posted: Sun Aug 04, 2019 3:14 pm
by Maxim
Hello normann!
Sorry for the late reply, is this issue still actual for you?

Re: ERROR: Sorry, portal is on maintenance. It may take some time.

Posted: Sat May 02, 2020 7:34 pm
by vondess
It was working for about a month and than out of sudden i'm getting this error for about a week.