[solved] Desktop editor on clean Ubuntu 20.04 - unmet dependencies

Issues during installation and related to database
Post Reply
zilexa
Posts: 2
Joined: Thu Sep 03, 2020 12:55 pm

[solved] Desktop editor on clean Ubuntu 20.04 - unmet dependencies

Post by zilexa » Thu Sep 03, 2020 1:02 pm

I cannot install OnlyOffice Desktop Editors via the Only Office repository.

After adding key, the repository and running apt-get update:

Code: Select all

sudo apt-get install onlyoffice-desktopeditors
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 onlyoffice-desktopeditors : Depends: fonts-dejavu but it is not installable or
                                      ttf-dejavu but it is not installable
                             Depends: fonts-crosextra-carlito but it is not installable
                             Recommends: fonts-takao-gothic but it is not installable
E: Unable to correct problems, you have held broken packages.
I don't actually have broken packages. I did install MS Office fonts earlier, they work fine in LibreOffice and should not cause this issue.
Other than that this is a clean Ubuntu 20.04.1 LTS install with kernel upgraded to 5.8 because that's the version that contains drivers for my AMD hardware.

How can I solve this issue? I tried installing fonts-dejavu but it does not exist.
Last edited by zilexa on Thu Sep 10, 2020 2:49 pm, edited 1 time in total.

Alexandre
Posts: 163
Joined: Thu Dec 12, 2019 11:08 am

Re: Desktop editor on clean Ubuntu 20.04 - unmet dependencies

Post by Alexandre » Mon Sep 07, 2020 10:59 am

Hello zilexa.
Please point me to the guide which you used. I just tested ONLYOFFICE desktop installation on the Ubuntu 20.04 (with kernel v.5.8 update). Everything is well, see screenshot.

The error is not reproducible on a totally clean installation. My steps: install Ubuntu 20.04 – install kernel update to v.5.8 – install ONLYOFFICE Desktop Editors from repository via guide: https://helpcenter.onlyoffice.com/deskt ... buntu.aspx
Could you please repeat your installation (totally clean, without any additional apps or changes)?
Please let me know the result.
Attachments
Ubuntu 20.04.png
Ubuntu 20.04.png (85.23 KiB) Viewed 585 times

zilexa
Posts: 2
Joined: Thu Sep 03, 2020 12:55 pm

Re: Desktop editor on clean Ubuntu 20.04 - unmet dependencies

Post by zilexa » Thu Sep 10, 2020 2:49 pm

You are correct, I don't know what the issue was. I believe I should have rebooted right after updating from clean 20.04 to 20.04.1 because after a reboot, all was fine and I could install perfectly.

I have a single remaining question:
How can I set the document language to Nederlands (Dutch) by default for every (new) document? Now English is standard. Everytime I create a new document, the language is English US and I have to change it manually.

Also, If I would want to contribute to get a Dutch UI, where can I apply?

Alexandre
Posts: 163
Joined: Thu Dec 12, 2019 11:08 am

Re: [solved] Desktop editor on clean Ubuntu 20.04 - unmet dependencies

Post by Alexandre » Tue Sep 15, 2020 9:27 am

Hello zilexa.
How can I set the document language to Nederlands (Dutch) by default for every (new) document? Now English is standard. Everytime I create a new document, the language is English US and I have to change it manually.
We know about this issue. Hotfix is planned in the next version of Desktop Editors. Unfortunately, I can’t provide you with exact time frames of the release.
Also, If I would want to contribute to get a Dutch UI, where can I apply?
Let’s start here: https://helpcenter.onlyoffice.com/deskt ... uages.aspx
You can contact via documentation@onlyoffice.com about the translation.

Post Reply