How to disable email confirmation in Community Server

Locked
jxmsz001
Posts: 6
Joined: Tue Oct 13, 2015 7:11 am

How to disable email confirmation in Community Server

Post by jxmsz001 » Tue Oct 13, 2015 9:10 am

Hey Guys. I have deploy an OnlyOffice Community Server on a local server. But the working environment is not connectting to the Internet, and we don't want a email server. What configuration should I do to skip the email confirmation process when I need to register a new user?

User avatar
AnaMih
Posts: 264
Joined: Mon Aug 25, 2014 10:15 am

Re: How to disable email confirmation in Community Server

Post by AnaMih » Thu Oct 15, 2015 1:05 pm

There is two methods to add users without sending an email invitation.
Method 1: To invite users to your portal by the invitation link. So each of the users can set his own password.
Method 2: To add users using csv-file to "People" module. Then open Data Base, find "core_user" table, change "Status" and "Status activation" to "1". It is needed to set passwords for the users (DB -> "Core_usersecurity"). As all the passwords are encrypted, you can copy the encrypted password of your user(or any other earlier created "test" user) and past it to all new users. So all the users created in this way will have the same password.

jxmsz001
Posts: 6
Joined: Tue Oct 13, 2015 7:11 am

Re: How to disable email confirmation in Community Server

Post by jxmsz001 » Fri Oct 16, 2015 2:05 am

AnaMih wrote:There is two methods to add users without sending an email invitation.
Method 1: To invite users to your portal by the invitation link. So each of the users can set his own password.
Method 2: To add users using csv-file to "People" module. Then open Data Base, find "core_user" table, change "Status" and "Status activation" to "1". It is needed to set passwords for the users (DB -> "Core_usersecurity"). As all the passwords are encrypted, you can copy the encrypted password of your user(or any other earlier created "test" user) and past it to all new users. So all the users created in this way will have the same password.
Thank you for your help!

Locked