Switch to HTTPS and run under service account => SocketIO issue

Post Reply
lukas.belak
Posts: 5
Joined: Tue Jul 31, 2018 10:55 am

Switch to HTTPS and run under service account => SocketIO issue

Post by lukas.belak » Mon Nov 25, 2019 4:51 pm

Hello, I'd like to ask for help.

I set a hostname for only office server in IIS, I made it run under a service account, all onlyoffice services like backup, feed, jabber etc now run under same service account.
I also enabled url rewrite rule 'http to https' in IIS.
Main modules works fine, they are accessible, but in chrome's developer tools i see errors like " GET https://onlyoffice.xcdev.sk/socketio/so ... &t=MwZPp_7 502 "
Chat (talk module) does not work anymore.

I am not sure which version I use, but I downloaded it in august 2018.

Would you be able to tell me what I am missing, how to resolve this issue?
If you need more info, ask, please.
Thanks in advance,

Lukas

Carl
Posts: 221
Joined: Thu Apr 12, 2018 10:00 am

Re: Switch to HTTPS and run under service account => SocketIO issue

Post by Carl » Tue Nov 26, 2019 9:28 am

Hello Lukas,

Please make sure you ran all the steps from this instruction to switch the portal to HTTPS:
https://helpcenter.onlyoffice.com/serve ... https.aspx

I also recommend to install the latest Community Server version:
https://sourceforge.net/projects/teamla ... ityServer/

lukas.belak
Posts: 5
Joined: Tue Jul 31, 2018 10:55 am

Re: Switch to HTTPS and run under service account => SocketIO issue

Post by lukas.belak » Tue Nov 26, 2019 10:11 am

I believe I ran all the steps from swithc to https instructions.

I cannot install latest version as I have aleady done few small changes.

Any other ideas?

Carl
Posts: 221
Joined: Thu Apr 12, 2018 10:00 am

Re: Switch to HTTPS and run under service account => SocketIO issue

Post by Carl » Tue Dec 03, 2019 1:27 pm

Hello Lukas,

Please make sure WebSocket support is enabled on your server.
https://docs.microsoft.com/en-us/iis/ge ... ol-support

lukas.belak
Posts: 5
Joined: Tue Jul 31, 2018 10:55 am

Re: Switch to HTTPS and run under service account => SocketIO issue

Post by lukas.belak » Tue Dec 03, 2019 6:24 pm

Hello Carl,

It is enabled.

Should not I do like it is described here https://stackoverflow.com/questions/117 ... express-js , should I?

Post Reply