Page 1 of 1

Not copying sent email to IMAP sent Items

Posted: Wed Jun 19, 2019 1:22 pm
by Bruno Morais
Hi,
I have a OnlyOffice 9.5.4.553 community server running on Docker. I have IMAP/SMTP account configured in each user. When I send an email, the message arrives to the destination so SMTP is working. The problem is that after sending the email, OnlyOffice is not copying the sent email to IMAP server sent items.
Anyone has an idea of what could be the issue?

Regards,
Bruno Morais

Re: Not copying sent email to IMAP sent Items

Posted: Thu Jun 20, 2019 6:57 am
by Maxim
Hello Bruno Morais!
Anyone has an idea of what could be the issue?
It is not a bug, Mail works as mail aggregator, it doesn't support full IMAP features. We have not enabled this option (synchronization) because it would increase server's loading.

Re: Not copying sent email to IMAP sent Items

Posted: Thu Jun 27, 2019 3:03 pm
by esp_onlyoffice
Wow, that's quite an unexpected shortcoming!
That's pretty much the very first implementation of IMAP I've seen that uses it as POP3 for inbox-download-copy only.
We are preparing our OnlyOffice server for internal rollout and just stumbled upon this issue

Is there a way to enable the fully sync on a OnlyOffice Enterprise v10 Docker install (no mailserver Container)?
If not, is there an ETA on when this feature will be available?

As it stanbds now it's pretty much useless to us, as pretty much everyone is expecting mail accounts to be in sync, no matter where and how you access them, except for the rare cases of some users still using POP3, which by todays Standards is quite a dinosaur.

Thanks for some Feedback

Regards
Juri

Re: Not copying sent email to IMAP sent Items

Posted: Mon Jul 01, 2019 6:57 am
by Maxim
Hello esp_onlyoffice!
Is there a way to enable the fully sync on a OnlyOffice Enterprise v10 Docker install (no mailserver Container)?
Unfortunately there is no way.
If not, is there an ETA on when this feature will be available?
For now there is no information when IMAP sync will be available.

Re: Not copying sent email to IMAP sent Items

Posted: Tue May 12, 2020 8:41 pm
by joker35
Hello,

I have installed Community Server and was hoping to use OO as email aggregator but I am experiencing issues with OO not doing a full IMAP sync and therefore makes it less useful when also checking Emails on my phone.

Otherwise I was getting exited to use OO to check Email from my desktop and laptop but now I wonder what the purpose would be to use Mail in OO when it doesn't do a full IMAP sync.

Is it just me having this impression as now I am back to exploring the mail option in NextCloud but I thought the UI in OO was more responsive?

Regards
Lars