DocumentServer : problem with MySQL dependencie

Issues during installation and related to database
Post Reply
Yoann
Posts: 27
Joined: Wed Jan 20, 2016 10:43 am

DocumentServer : problem with MySQL dependencie

Post by Yoann » Tue Feb 23, 2016 4:18 pm

Hi,

I've try to install Onlyoffice Document Server on Debian Jessie through debian repositories.
I've installed all required components and dependencies but when I run:
apt-get install onlyoffice-documentserver
I get:
The following packages have unmet dependencies:
onlyoffice-documentserver : Depends: mysql-server-5.6 (>= 5.6.4)
E: Unable to correct problems, you have held broken packages.

MySQL is installed in the proper version :

# dpkg -l mysql-server
ii mysql-server 5.6.29-1debian8 amd64 MySQL Server meta package depending on latest version

I think the problem come from the name of the MySQL Package : it's mysql-server and not mysql-server-5.6

this is the dependencies for onlyoffice-documentserver :

Depends: libc6 (>= 2.17), libcurl3 (>= 7.16.2), libgcc1 (>= 1:4.1.1), libstdc++6 (>= 4.9.0), debconf (>= 0.5) | debconf-2.0, adduser, mysql-server-5.6 (>= 5.6.4), mono-runtime (>= 3.2.0), mono-fastcgi-server, nginx (>= 1.3.13), nodejs (>=
0.10), libxml2, supervisor (>= 3.0b2), python3, python3-uno, libreoffice-writer, libreoffice-calc, libreoffice-impress, fonts-dejavu, fonts-liberation, ttf-mscorefonts-installer, fonts-crosextra-carlito, fonts-takao-gothic, libfcgi, timelimit

And for example, this is the dependencies for onlyoffice-documentserver-enterprise :

Depends: gconf-service, libasound2 (>= 1.0.16), libc6 (>= 2.17), libcairo2 (>= 1.6.0), libcap2 (>= 2.10), libcups2 (>= 1.4.0), libcurl3 (>= 7.16.2), libcurl3-gnutls (>= 7.16.2), libdbus-1-3 (>= 1.2.14), libexpat1 (>= 2.0.1), libfontconfig1 (>= 2.9.0), libfreetype6 (>= 2.3.9), libgcc1 (>= 1:4.1.1), libgconf-2-4 (>= 2.31.1), libgl1-mesa-glx | libgl1, libglib2.0-0 (>= 2.35.9), libgtk2.0-0 (>= 2.24.0), libgtkglext1, libharfbuzz0b (>= 0.9.11), libnspr4 (>= 2:4.9-2~) | libnspr4-0d (>= 1.8.0.10), libnss3 (>= 2:3.14.3), libpango-1.0-0 (>= 1.22.0), libpangocairo-1.0-0 (>= 1.14.0), libstdc++6 (>= 4.9.0), libx11-6 (>= 2:1.4.99.1), libxcomposite1 (>= 1:0.3-1), libxcursor1 (>> 1.1.2), libxdamage1 (>= 1:1.1), libxext6, libxfixes3, libxi6 (>= 2:1.2.99.4), libxml2 (>= 2.7.4), libxrandr2 (>= 2:1.2.99.2), libxrender1, libxtst6, zlib1g (>= 1:1.1.4), debconf (>= 0.5) | debconf-2.0, adduser, mysql-server (>= 5.6.4), redis-server, rabbitmq-server, nginx-extras (>= 1.3.13), nodejs (>= 4.2.0), libboost-regex-dev, supervisor (>= 3.0b2), fonts-dejavu, fonts-liberation, ttf-mscorefonts-installer, fonts-crosextra-carlito, fonts-takao-gothic, fonts-opensymbol, xvfb, libgconf2-4, bomstrip

I think, that's why i have this problem. Could you correct your package and change the name from mysql-server-5.6 to mysql-server ?

Thanks a lot for your help,
Yoann.

Yoann
Posts: 27
Joined: Wed Jan 20, 2016 10:43 am

Re: DocumentServer : problem with MySQL dependencie

Post by Yoann » Wed Feb 24, 2016 9:35 am

Hi,

I build a new package with the correct name (mysql-server (>= 5.6.4)) and it's works :)
Could you, please, fix your package ?

Thanks,
Yoann.

Dean
Posts: 700
Joined: Tue Sep 30, 2014 11:04 am

Re: DocumentServer : problem with MySQL dependencie

Post by Dean » Wed Mar 09, 2016 10:21 am

Corrected in the new (test) version. We will release it ASAP.

Lunatic_FR
Posts: 1
Joined: Sun Jun 26, 2016 3:24 pm

Re: DocumentServer : problem with MySQL dependencie

Post by Lunatic_FR » Sun Jun 26, 2016 3:35 pm

Hi!

I'm a new OnlyOffice Community user and I have the same error about MySQL dependencie.

I'm running Ubuntu Server 16.04 LTS
user@onlyoffice:/tmp$ sudo apt-get install onlyoffice-documentserver
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation :


Les paquets suivants contiennent des dépendances non satisfaites :
onlyoffice-documentserver : Dépend: mysql-server-5.6 (>= 5.6.4) mais il n'est pas installable
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».
My MySQL Server version below:
user@onlyoffice:/tmp$ mysql -V
mysql Ver 14.14 Distrib 5.7.12, for Linux (x86_64) using EditLine wrapper
Have you released the corrected version ?

Have you a solution to bypass this error?

Thanks
;)

e-got
Posts: 1
Joined: Sat Jul 22, 2017 6:20 pm

Re: DocumentServer : problem with MySQL dependencie

Post by e-got » Sat Jul 22, 2017 6:25 pm

I had the same problem on a RPi.

Code: Select all

Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Vous pouvez lancer « apt-get -f install » pour corriger ces problèmes :
Les paquets suivants contiennent des dépendances non satisfaites :
 mysql-server : Dépend: mysql-server-5.5 mais ne sera pas installé
 putty : Dépend: putty-tools mais ne sera pas installé
E: Dépendances non satisfaites. Essayez « apt-get -f install » sans paquet
(ou indiquez une solution).
I try

Code: Select all

apt-get -f install
But is not enough ...

Maxim
Posts: 1786
Joined: Tue Oct 11, 2016 2:34 pm

Re: DocumentServer : problem with MySQL dependencie

Post by Maxim » Mon Jul 24, 2017 6:58 am

Hello e-got!
Document Server for Linux system requirements
For Debian, Ubuntu and derivatives
OS 64-bit Debian, Ubuntu or other compatible distribution with kernel version 3.13 or later
PostgreSQL: version 9.1 or later
NGINX: version 1.3.13 or later
Node.js: version 6.9.1 or later
libstdc++6: version 4.8.4 or later
Redis
RabbitMQ
As you can see there is no MySQL, there is PostgreSQL
Please specify what version of the Document Server do you use?

Post Reply