Page 1 of 1

Dependency on mono

Posted: Tue Jul 24, 2018 9:56 am
by thalperi
tamir@minimi:~$ sudo apt-get install onlyoffice-communityserver
[sudo] password for tamir:
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
onlyoffice-communityserver : Depends: mono-webserver-hyperfastcgi but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

and then

tamir@minimi:~$ sudo apt-get install mono-webserver-hyperfastcgi
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
mono-webserver-hyperfastcgi : Depends: libevent-2.0-5 (>= 2.0.10-stable) but it is not installable
Depends: libevent-pthreads-2.0-5 (>= 2.0.10-stable) but it is not installable
E: Unable to correct problems, you have held broken packages.

Could somebody please help me resolve these dependency issues?

Re: Dependency on mono

Posted: Thu Jul 26, 2018 7:38 am
by Maxim
Hello thalperi!
What is your server OS?

Re: Dependency on mono

Posted: Fri Aug 17, 2018 12:43 am
by bevy
I am running into this same issue on Ubuntu 18.04.

Steps to reproduce:
```
sudo apt-key adv --keyserver hkp://keyserver.ubuntu.com:80 --recv-keys 3FA7E0328081BFF6A14DA29AA6A19B38D3D831EF
echo "deb https://download.mono-project.com/repo/ubuntu stable-bionic main" | sudo tee /etc/apt/sources.list.d/mono-official-stable.list
sudo apt update
sudo apt install mono-complete
sudo apt-key adv --keyserver hkp://keyserver.ubuntu.com:80 --recv-keys CB2DE8E5
sudo echo "deb http://download.onlyoffice.com/repo/debian squeeze main" | sudo tee /etc/apt/sources.list.d/onlyoffice.list
sudo apt update
sudo apt install onlyoffice-communityserver
```

Result:
```
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
onlyoffice-communityserver : Depends: mono-webserver-hyperfastcgi but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
```

Re: Dependency on mono

Posted: Fri Jan 25, 2019 1:57 pm
by ayubbhay
Same issues here, with same OS.

Re: Dependency on mono

Posted: Fri Feb 01, 2019 12:38 pm
by dimaskin
ayubbhay wrote:
Fri Jan 25, 2019 1:57 pm
Same issues here, with same OS.
+1

Re: Dependency on mono

Posted: Wed Feb 13, 2019 11:56 am
by Carl
Hello,

The issue appears only when installing Community Server manually. If you use the script, the installation goes correctly. The issue will be fixed in the version 10.0 of Community Server. We are planning to release it in March. Sorry for the inconvenience.