Dependency on mono

Issues during installation and related to database
Post Reply
thalperi
Posts: 1
Joined: Tue Jul 24, 2018 9:41 am

Dependency on mono

Post by thalperi » Tue Jul 24, 2018 9:56 am

tamir@minimi:~$ sudo apt-get install onlyoffice-communityserver
[sudo] password for tamir:
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
onlyoffice-communityserver : Depends: mono-webserver-hyperfastcgi but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

and then

tamir@minimi:~$ sudo apt-get install mono-webserver-hyperfastcgi
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
mono-webserver-hyperfastcgi : Depends: libevent-2.0-5 (>= 2.0.10-stable) but it is not installable
Depends: libevent-pthreads-2.0-5 (>= 2.0.10-stable) but it is not installable
E: Unable to correct problems, you have held broken packages.

Could somebody please help me resolve these dependency issues?

Maxim
Posts: 2017
Joined: Tue Oct 11, 2016 2:34 pm

Re: Dependency on mono

Post by Maxim » Thu Jul 26, 2018 7:38 am

Hello thalperi!
What is your server OS?

bevy
Posts: 1
Joined: Thu Aug 16, 2018 11:01 pm

Re: Dependency on mono

Post by bevy » Fri Aug 17, 2018 12:43 am

I am running into this same issue on Ubuntu 18.04.

Steps to reproduce:
```
sudo apt-key adv --keyserver hkp://keyserver.ubuntu.com:80 --recv-keys 3FA7E0328081BFF6A14DA29AA6A19B38D3D831EF
echo "deb https://download.mono-project.com/repo/ubuntu stable-bionic main" | sudo tee /etc/apt/sources.list.d/mono-official-stable.list
sudo apt update
sudo apt install mono-complete
sudo apt-key adv --keyserver hkp://keyserver.ubuntu.com:80 --recv-keys CB2DE8E5
sudo echo "deb http://download.onlyoffice.com/repo/debian squeeze main" | sudo tee /etc/apt/sources.list.d/onlyoffice.list
sudo apt update
sudo apt install onlyoffice-communityserver
```

Result:
```
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
onlyoffice-communityserver : Depends: mono-webserver-hyperfastcgi but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
```

ayubbhay
Posts: 1
Joined: Fri Jan 25, 2019 1:53 pm

Re: Dependency on mono

Post by ayubbhay » Fri Jan 25, 2019 1:57 pm

Same issues here, with same OS.

dimaskin
Posts: 1
Joined: Fri Feb 01, 2019 12:37 pm

Re: Dependency on mono

Post by dimaskin » Fri Feb 01, 2019 12:38 pm

ayubbhay wrote:
Fri Jan 25, 2019 1:57 pm
Same issues here, with same OS.
+1

Carl
Posts: 479
Joined: Thu Apr 12, 2018 10:00 am

Re: Dependency on mono

Post by Carl » Wed Feb 13, 2019 11:56 am

Hello,

The issue appears only when installing Community Server manually. If you use the script, the installation goes correctly. The issue will be fixed in the version 10.0 of Community Server. We are planning to release it in March. Sorry for the inconvenience.

bud4unc
Posts: 1
Joined: Tue Jul 23, 2019 10:24 pm

Re: Dependency on mono

Post by bud4unc » Tue Jul 23, 2019 10:31 pm

Seems this is not resolved?

The following packages have unmet dependencies: onlyoffice-communityserver :
Depends: mono-webserver-hyperfastcgi but it is not going to be installed
Depends: elasticsearch (= 6.5.0) but 7.2.0 is to be installedE:
Unable to correct problems, you have held broken packages.

Maxim
Posts: 2017
Joined: Tue Oct 11, 2016 2:34 pm

Re: Dependency on mono

Post by Maxim » Thu Jul 25, 2019 8:31 am

Hello bud4unc!
Please specify what instruction you followed to install Community Server.

nillenille2
Posts: 25
Joined: Thu Oct 06, 2016 2:26 pm

Re: Dependency on mono

Post by nillenille2 » Thu Feb 06, 2020 3:54 pm

I'm having the same problem. Onlyoffice depends on the old version of Elasticsearch, but you can't install version 6.5.0 on Debian 'Buster'. Only version 6.8.x and up.

rf_
Posts: 1
Joined: Tue Feb 25, 2020 11:40 am

Re: Dependency on mono

Post by rf_ » Tue Feb 25, 2020 11:49 am

That debian install script looks very handy, now I'm wondering why I'm installing document server & community server by hand instead of installing community edition open-source variant.

In any case, I looked through the scripts that get sourced for the automated install with the script, and the relevant bits seem to be:

Code: Select all

if [[ "$DIST" = "ubuntu" || "$DIST" = "debian" ]] && [[ "$DISTRIB_CODENAME" = "bionic" || "$DISTRIB_CODENAME" = "buster" ]]; then
        echo "deb https://d2nlctn12v279m.cloudfront.net/repo/mono/ubuntu bionic main" | tee /etc/apt/sources.list.d/mono-extra.list
        apt-key adv --keyserver hkp://keyserver.ubuntu.com:80 --recv-keys CB2DE8E5
        hyperfastcgi_version="0.4-7"
else
        hyperfastcgi_version="0.4-4"
fi
apt-get update

apt-get install mono-webserver-hyperfastcgi=$hyperfastcgi_version
Since I'm on bionic and already have the onlyoffice dev's PGP key, I only needed these steps in essence:

Code: Select all

# for bionic:
echo "deb https://d2nlctn12v279m.cloudfront.net/repo/mono/ubuntu bionic main" | sudo tee /etc/apt/sources.list.d/mono-extra.list
sudo apt-get update
sudo apt-get install mono-webserver-hyperfastcgi=0.4-7
Also make sure to install elasticsearch like this if you do it all by hand:

Code: Select all

sudo apt-get install elasticsearch=6.5.0
it should be available if you followed elasticsearch install guide and have done something like

Code: Select all

wget -qO - https://artifacts.elastic.co/GPG-KEY-elasticsearch | sudo apt-key add -
sudo apt-get install apt-transport-https
echo "deb https://artifacts.elastic.co/packages/6.x/apt stable main" | sudo tee -a /etc/apt/sources.list.d/elastic-6.x.list
Edit:
After that both pieces of software will try to run on port 80, which will cause nginx to report a 502 Bad Gateway.

To reconfigure doc-server to 8083:

Code: Select all

echo onlyoffice-documentserver onlyoffice/ds-port select 8083 | sudo debconf-set-selections
sudo dpkg-reconfigure onlyoffice-documentserver
You can check /etc/nginx/conf.d/ds.conf if it'll use 8083 after that.

Cheers,
rf_

Post Reply