French encoding

Issues during installation and related to database
NeoPhil
Posts: 9
Joined: Tue Feb 28, 2017 2:05 pm

French encoding

Post by NeoPhil » Wed Sep 06, 2017 1:07 pm

Hello,

After a clean install on Ubuntu 16.04 (repository method, not docker), with HTTPS and Document Server working, i can't setup the french translation correctly.

Seems the encoding is wrong, for exemple :
Aucune tâche n'a été encore créée
Les tâches vous permettent de distribuer le travail aux participants du projet de manière égale, de définir les responsables pour les différentes parties du projet. Ajoutez des tâches, déterminez ceux qui sont responsables, gérez le travail d'équipe.
I tried to change database charset to UTF-8, but no luck...

Any ideas ?

Thanks !

Maxim
Posts: 1750
Joined: Tue Oct 11, 2016 2:34 pm

Re: French encoding

Post by Maxim » Wed Sep 06, 2017 1:45 pm

Hello NeoPhil!
Please specify what instruction you followed to install Onlyoffice and
i can't setup the french translation correctly
translation?
Onlyoffice doesn't translate.

NeoPhil
Posts: 9
Joined: Tue Feb 28, 2017 2:05 pm

Re: French encoding

Post by NeoPhil » Wed Sep 06, 2017 2:03 pm

Thanks for answer Maxim,

I follow this instruction to install OO :
https://helpcenter.onlyoffice.com/serve ... ation.aspx

It's a fresh Ubuntu server 16.04 (LXC Container on Proxmox Host). No error during install, OO working like a charm.

Sorry, as "translation", I meen simply change language to "French (France)" in interface settings.

Maxim
Posts: 1750
Joined: Tue Oct 11, 2016 2:34 pm

Re: French encoding

Post by Maxim » Mon Sep 11, 2017 7:14 am

Nello NeoPhil!
It needs to change database charset to UTF-8.
What mysql version did you install?
Ia there one database only?

NeoPhil
Posts: 9
Joined: Tue Feb 28, 2017 2:05 pm

Re: French encoding

Post by NeoPhil » Thu Sep 14, 2017 4:58 pm

Maxim wrote:Nello NeoPhil!
It needs to change database charset to UTF-8.
What mysql version did you install?
Ia there one database only?
Hello Maxim,
I think database is already to UTF-8.

Code: Select all

+------------------------+-------+
| Variable_name          | Value |
+------------------------+-------+
| character_set_database | utf8  |
+------------------------+-------+
1 row in set (0,00 sec)
and MySQL Version is 5.7.19

... I don't understand, some chararcters are good and not others... :
Attachments
onlyofficepb.PNG
French Charset
onlyofficepb.PNG (14.72 KiB) Viewed 3101 times

Maxim
Posts: 1750
Joined: Tue Oct 11, 2016 2:34 pm

Re: French encoding

Post by Maxim » Fri Sep 15, 2017 12:27 pm

Hello NeoPhil!
We are trying to find the problem, please wait. I will try to reply as soon as possible.

NeoPhil
Posts: 9
Joined: Tue Feb 28, 2017 2:05 pm

Re: French encoding

Post by NeoPhil » Mon Sep 18, 2017 8:49 am

Maxim wrote:Hello NeoPhil!
We are trying to find the problem, please wait. I will try to reply as soon as possible.
Thank you very much.

NeoPhil
Posts: 9
Joined: Tue Feb 28, 2017 2:05 pm

Re: French encoding

Post by NeoPhil » Mon Sep 18, 2017 3:07 pm

Hello,
For information, I just try another fresh install folowing this guide : https://helpcenter.onlyoffice.com/serve ... ation.aspx

>> Same results when switching language to French...

:(

Maxim
Posts: 1750
Joined: Tue Oct 11, 2016 2:34 pm

Re: French encoding

Post by Maxim » Tue Sep 19, 2017 6:26 am

Hello NeoPhil!
Thank you for the information!
Try to install docker version

Blackjack
Posts: 3
Joined: Sun Jan 21, 2018 8:05 pm

Re: French encoding

Post by Blackjack » Sun Jan 21, 2018 8:12 pm

Hi Maxim,

i have the same cofiguration with https, Ubuntu 16.04 (LXC Container Proxmox) and the same problem with German special characters :shock:
I already checked the mysql database and it is also in UTF-8.

Thanks for your help

Post Reply