Page 1 of 1

WebDAV and Nuxeo

Posted: Wed Feb 03, 2016 10:57 am
by Yoann

i'm trying to set a WebDAV connection with a Nuxeo server.
The connection is successfully create and i can access on the root folder off the nuxeo webdav server, but if i try to acces a folder I get the following error: "Object reference not set to an instance of an object"

the full log :

2016-02-02 16:26:56,927 ERROR [Threadpool worker] ASC.Files - System.NullReferenceException: Object reference not set to an instance of an object
at AppLimit.CloudComputing.SharpBox.StorageProvider.WebDav.Logic.WebDavRequestParser.CreateObjectsFromNetworkStream (System.IO.Stream data, System.String targetUrl, IStorageProviderService service, IStorageProviderSession session, AppLimit.CloudComputing.SharpBox.StorageProvider.WebDav.Logic.NameBaseFilterCallback callback) [0x00000] in <filename unknown>:0
at AppLimit.CloudComputing.SharpBox.StorageProvider.WebDav.Logic.WebDavStorageProviderService.RequestResourceFromWebDavShare (IStorageProviderSession session, System.String resourceUrl, System.Collections.Generic.List`1& childs) [0x00000] in <filename unknown>:0
at AppLimit.CloudComputing.SharpBox.StorageProvider.WebDav.Logic.WebDavStorageProviderService.RefreshResource (IStorageProviderSession session, ICloudFileSystemEntry resource) [0x00000] in <filename unknown>:0
at AppLimit.CloudComputing.SharpBox.StorageProvider.CachedServiceWrapper.RefreshResource (IStorageProviderSession session, ICloudFileSystemEntry resource) [0x00000] in <filename unknown>:0
at AppLimit.CloudComputing.SharpBox.StorageProvider.BaseObjects.BaseDirectoryEntry.RefreshResource () [0x00000] in <filename unknown>:0
at AppLimit.CloudComputing.SharpBox.StorageProvider.BaseObjects.BaseDirectoryEntry.GetEnumerator () [0x00000] in <filename unknown>:0
at AppLimit.CloudComputing.SharpBox.StorageProvider.BaseObjects.BaseDirectoryEntry.System.Collections.IEnumerable.GetEnumerator () [0x00000] in <filename unknown>:0
at System.Linq.Enumerable+<CreateOfTypeIterator>c__IteratorC`1[AppLimit.CloudComputing.SharpBox.ICloudDirectoryEntry].MoveNext () [0x00000] in <filename unknown>:0
at System.Linq.Enumerable+<CreateSelectIterator>c__Iterator10`2[AppLimit.CloudComputing.SharpBox.ICloudDirectoryEntry,ASC.Files.Core.Folder].MoveNext () [0x00000] in <filename unknown>:0
at System.Collections.Generic.List`1[ASC.Files.Core.Folder].AddEnumerable (IEnumerable`1 enumerable) [0x00000] in <filename unknown>:0
at System.Collections.Generic.List`1[ASC.Files.Core.Folder]..ctor (IEnumerable`1 collection) [0x00000] in <filename unknown>:0
at System.Linq.Enumerable.ToList[Folder] (IEnumerable`1 source) [0x00000] in <filename unknown>:0
at ASC.Files.Thirdparty.Sharpbox.SharpBoxFolderDao.GetFolders (System.Object parentId) [0x00000] in <filename unknown>:0
at ASC.Files.Thirdparty.Sharpbox.SharpBoxFolderDao.GetFolders (System.Object parentId, ASC.Files.Core.OrderBy orderBy, FilterType filterType, Guid subjectID, System.String searchText) [0x00000] in <filename unknown>:0

at ASC.Web.Files.Utils.EntryManager.GetEntries (IFolderDao folderDao, ASC.Files.Core.Folder parent, FilterType filter, Guid subjectId, ASC.Files.Core.OrderBy orderBy, System.String searchText, Int32 from, Int32 count, System.Int32& total) [0x00000] in <filename unknown>:0
at ASC.Web.Files.Services.WCFService.FileStorageServiceController.GetFolderItems (System.String parentId, Int32 from, Int32 count, FilterType filter, ASC.Files.Core.OrderBy orderBy, System.String ssubject, System.String searchText) [0x00000] in <filename unknown>:0

By the way, i know the Nuxeo WEBDAV works because I can map to it from within Windows and access all files with the same address, login and password I use in Onlyoffice to make the connection.

Thanks for your help,

Re: WebDAV and Nuxeo

Posted: Thu Mar 17, 2016 7:27 am
by Dean
Are there any special symbols in a password?

Re: WebDAV and Nuxeo

Posted: Fri Mar 18, 2016 9:49 am
by Yoann
no, only alphanumerics characters.
But how can the problem can be related to the password ?
The connection is successfully create and i can access on the root folder off the nuxeo webdav server, but if i try to acces a folder I get the following error: "Object reference not set to an instance of an object"
webdav_nuxeo_2.jpg (35.81 KiB) Viewed 2560 times

Thanks for your help,

Re: WebDAV and Nuxeo

Posted: Thu Jan 11, 2018 8:37 am
by dsi-lille

it's an old thread but we still have this issue and we really want to establish a connection between OnlyOffice and our ECM Solution (Nuxeo) with WebDav.

I ran some test by developing a little piece of code who just display the content of a folder with WebDav.

With the latest version of Sharpbox available on NuGet (, i did not have this error.
With the same version that use OnlyOffice (Sharpbox v1.1.0.446), i get the error...

So whatever generate the error, it's solved with the latest version of Sharpbox.
Could you upgrade this library ?