Page 1 of 1

Invitation Mail Issue for New Users

Posted: Fri Jun 26, 2015 2:01 am
by lebienaime
Dear moderator, please feel free to edit my post as you see fit since it contains both error/bug report and question. It could be useful for the other members if what I did is correct.

Recently, I had a problem with registering new users.
The registered user didn't get the invitation to their mailbox.

My installation is OnlyOffice 8.5 on CentOS 7 with kernel version 3.10.0-229.4.2
The prerequisites have been met. No issue with the administrator registration, which is why I assumed that at a later date, user registration will be successful.

However, when I tried to invite new users to the portal, the email didn't reach the user's mailbox.

I browsed through the /var/log/onlyoffice and tried to find any entries relevant to that date and I found an interesting error in

2015-06-26 08:28:36,300 ERROR [1] ASC.TeamLabSvc - Can not start service NotifyServiceLauncher: MySql.Data.MySqlClient.MySqlException: Unable to connect to any of the specified MySQL hosts.
at MySql.Data.MySqlClient.NativeDriver.Open () [0x00000] in <filename unknown>:0
at MySql.Data.MySqlClient.Driver.Open () [0x00000] in <filename unknown>:0
at MySql.Data.MySqlClient.Driver.Create (MySql.Data.MySqlClient.MySqlConnectionStringBuilder settings) [0x00000] in <filename unknown>:0
at MySql.Data.MySqlClient.MySqlPool.CreateNewPooledConnection () [0x00000] in <filename unknown>:0
at MySql.Data.MySqlClient.MySqlPool.GetPooledConnection () [0x00000] in <filename unknown>:0
at MySql.Data.MySqlClient.MySqlPool.TryToGetDriver () [0x00000] in <filename unknown>:0

I figured that it must have something to do with the mysql connections and I tried my credentials on the mysql server . It worked properly.

What I did to fix this issue is to reconfigure by running the to enter the mysql connection parameters to onlyoffice.

Is it the correct way to fix this issue? Also, is there an alternative method to resolve this issue?


Re: Invitation Mail Issue for New Users

Posted: Fri Jun 26, 2015 9:37 am
by Dean
Try restarting onlyofficeNotify service, this may help. If it doesn't - running the once again is the only method.