Try the fastest and simplest way to install ONLYOFFICE

Can't install on Ubuntu 18.04?

Issues during installation and related to database

Can't install on Ubuntu 18.04?

Postby SparkyRih » Mon Jul 02, 2018 9:50 pm

I'm getting this error while trying to re-install onlyoffice-documentserver... I had it installed and working before, but while I was updating, an erro accured, so I removed onlyoffice-documentserver, but now I can't even install it anymore...

Setting up onlyoffice-documentserver (5.1.4-22) ...
dpkg: error processing package onlyoffice-documentserver (--configure):
installed onlyoffice-documentserver package post-installation script subprocess returned error exit status 127
Errors were encountered while processing:
onlyoffice-documentserver
E: Sub-process /usr/bin/dpkg returned an error code (1)
User avatar
SparkyRih
 
Posts: 2
Joined: Mon Jul 02, 2018 9:42 pm

Re: Can't install on Ubuntu 18.04?

Postby Maxim » Tue Jul 03, 2018 6:17 am

Hello!
Can't install on Ubuntu 18.04?

There must be problems with installation due to lack of some needed packages.
Onlyoffice doesn't support Ubuntu 18.04 for now.
Maxim
 
Posts: 1732
Joined: Tue Oct 11, 2016 2:34 pm

Re: Can't install on Ubuntu 18.04?

Postby SparkyRih » Tue Jul 03, 2018 8:41 pm

Ok thanks, well than I'll see if I can find out what I'm missing to see if I can get it to work again...
User avatar
SparkyRih
 
Posts: 2
Joined: Mon Jul 02, 2018 9:42 pm

Re: Can't install on Ubuntu 18.04?

Postby AndySputnik » Wed Aug 22, 2018 12:59 pm

Did you ever figure this out? I tried, but seems mono-complete has some broken dependencies on its Ubuntu 18 version.
AndySputnik
 
Posts: 7
Joined: Wed Aug 22, 2018 11:20 am

Re: Can't install on Ubuntu 18.04?

Postby Maxim » Mon Aug 27, 2018 6:36 am

Hello AndySputnik!
Please follow this instruction to install Document Server on Ubuntu 18.04
Maxim
 
Posts: 1732
Joined: Tue Oct 11, 2016 2:34 pm

Re: Can't install on Ubuntu 18.04?

Postby AndySputnik » Thu Aug 30, 2018 11:01 am

Maxim wrote:Hello AndySputnik!
Please follow this instruction to install Document Server on Ubuntu 18.04


Apologies. I didn't read the original post closely enough. It's the community server that doesn't install on Ubuntu 18 due to mono-complete having dependency issues. I ended up using Ubuntu 16 for this build.
AndySputnik
 
Posts: 7
Joined: Wed Aug 22, 2018 11:20 am


Return to Installation / Database

Who is online

Users browsing this forum: No registered users and 5 guests