Try the fastest and simplest way to install ONLYOFFICE

LDAP integration - users can't log in

Tech support for Enterprise Version

LDAP integration - users can't log in

Postby Potleezus » Thu Jun 28, 2018 11:21 am

Hi,

I'm using version 9.6 Enterprise. I used the docker version to install. My ldap users and groups are syncing correctly, however they can't log in. Only the local account I created during install can log in. Please help.
Potleezus
 
Posts: 4
Joined: Thu Jun 28, 2018 11:13 am

Re: LDAP integration - users can't log in

Postby Maxim » Fri Jun 29, 2018 8:07 am

Hello Potleezus!
Do you see LDAP users in 'People'?
....however they can't log in

Do they get any error? Do they try to log in using email?
Maxim
 
Posts: 1649
Joined: Tue Oct 11, 2016 2:34 pm

Re: LDAP integration - users can't log in

Postby Potleezus » Fri Jun 29, 2018 9:51 am

Hi Maxim,

Thanks for getting back to me.

1. Yes I can see my ldap users.
2. The error is: Invalid username or password

I've made sure that I'm using the correct username/password combination. We're using version 9.6.1
Potleezus
 
Posts: 4
Joined: Thu Jun 28, 2018 11:13 am

Re: LDAP integration - users can't log in

Postby Potleezus » Fri Jun 29, 2018 9:53 am

Just to add to the answer: Yes they are logging in using email.
Potleezus
 
Posts: 4
Joined: Thu Jun 28, 2018 11:13 am

Re: LDAP integration - users can't log in

Postby Potleezus » Fri Jun 29, 2018 12:20 pm

Hi Maxim,

I changed my time zone and disabled ldap groups then did a sync. I'm able to log in now. I need help with the groups. Every time I activate ldap groups in Onlyoffice, none of my ldap users can log in.
Potleezus
 
Posts: 4
Joined: Thu Jun 28, 2018 11:13 am

Re: LDAP integration - users can't log in

Postby Maxim » Mon Jul 02, 2018 12:37 pm

Hello Potleezus!
What about logs?
1. Enable extended logs
Code: Select all
docker exec -it onlyoffice-community-server sed -i 's/<level value="WARN" \/>/<level value="ALL" \/>/g' /var/www/onlyoffice/WebStudio/web.log4net.config

Code: Select all
docker exec -it onlyoffice-community-server service monoserve restart

2. See logs in /app/onlyoffice/CommunityServer/logs
3. i need your screenshot of LDAP settings
Maxim
 
Posts: 1649
Joined: Tue Oct 11, 2016 2:34 pm


Return to Enterprise Version

Who is online

Users browsing this forum: No registered users and 0 guests