Try the fastest and simplest way to install ONLYOFFICE

API project team functions not working as expected

Integration questions/issues

API project team functions not working as expected

Postby pciavald » Wed Jan 11, 2017 3:15 pm

Hi,

I my application I need to add a user to a project team using the API, and I noticed two functions don't behave as expected.
First, I used POST api/2.0/project/{projectid}/team with the project ID and one guid not yet in the project, and the effect was to empty the existing team leaving only the responsible in the team.
Then I used PUT api/2.0/project/{projectid}/team with the project ID and the list of guids that I got from the response of GET api/2.0/project/{projectid}/team and the added guid, and i got the same behaviour : I send the list of guids, onlyoffice empties the team except the responsible user.

To go around this problem I've used PUT api/2.0/project/{id} to update the project with a new participants collection, and it works perfectly. But I wanted to tell these functions don't seem to work as expected.
pciavald
 
Posts: 16
Joined: Wed Sep 21, 2016 5:07 pm

Re: API project team functions not working as expected

Postby Maxim » Thu Jan 12, 2017 10:31 am

Hello pciavald!
1 We tried to reproduce the issue but have no luck
2 OnlyOffice for web works with the same API and have no issue you described
3 We suppose that smth. wrong with your code, share it with us please to check it out.
Maxim
 
Posts: 1082
Joined: Tue Oct 11, 2016 2:34 pm


Return to API

Who is online

Users browsing this forum: No registered users and 1 guest

cron