Try the fastest and simplest way to install ONLYOFFICE

CommandService forcesave -> internal server error

Integration questions/issues

CommandService forcesave -> internal server error

Postby maaso » Wed Sep 26, 2018 4:11 pm

Hi,

We are trying to manually trigger a save on a moment of our choosing, and have implemented an API call to the CommandService to achieve this.

It sends the following JSON: { "c":"forcesave","key":"thedocumentkey" }. Additionally, based on the payload and a secret set in config, a token is generated and this is put in the Authentication header as a Bearer token. The token seems to be correct, if we omit it we will get error code 6 as expected.

However sending this command results in an error with code 3; this is an internal server error in the document server but

a) it does not mention what the problem is
b) there is nothing in the server's error.log or out.log to indicate a problem

What are we doing wrong?
maaso
 
Posts: 4
Joined: Wed Sep 26, 2018 3:01 pm

Re: CommandService forcesave -> internal server error

Postby Carl » Thu Sep 27, 2018 12:17 pm

Hello, we have replied to your request in our Helpdesk.
Carl
 
Posts: 63
Joined: Thu Apr 12, 2018 10:00 am

Re: CommandService forcesave -> internal server error

Postby maaso » Fri Sep 28, 2018 12:58 pm

Hi,

How can see the response? The support page still shows the "unanswered user request" icon
maaso
 
Posts: 4
Joined: Wed Sep 26, 2018 3:01 pm

Re: CommandService forcesave -> internal server error

Postby Carl » Wed Oct 03, 2018 12:13 pm

Hello,

The response was sent through helpdesk.onlyoffice.com, not support.onlyoffice.com. You should have received the log in credentials (sent at maarten_somers@gmail.com).
Carl
 
Posts: 63
Joined: Thu Apr 12, 2018 10:00 am

Re: CommandService forcesave -> internal server error

Postby maaso » Wed Oct 03, 2018 2:10 pm

Aha ok, that explains it. The e-mail address is wrong; the correct one is maarten_somers@peopleware.be
maaso
 
Posts: 4
Joined: Wed Sep 26, 2018 3:01 pm

Re: CommandService forcesave -> internal server error

Postby maaso » Mon Oct 15, 2018 12:04 pm

So there is no way for me to access this reply?
maaso
 
Posts: 4
Joined: Wed Sep 26, 2018 3:01 pm


Return to API

Who is online

Users browsing this forum: No registered users and 1 guest

cron