Try the fastest and simplest way to install ONLYOFFICE

Problems with DATE fields (saves with a day earlier)

Problems with DATE fields (saves with a day earlier)

Postby ghribas » Mon Feb 01, 2016 12:29 pm

Hello all,

We are currently facing some problems with OnlyOffice.
When creating a new Project/Task or when editing existing records, OnlyOffice changes the selected "Deadline Date" by a day earlier.

Examples:
1. If I create a new Task with deadline on 01/fev/2016, OnlyOffice changes the selected deadline and saves it as 31/jan/2016.
2. If I edit a Task with deadline on 01/fev/2016, OnlyOffice saves it as 31/jan/2016. If I edit it again, it will save it as 30/jan/2016.........

Even if the start date is set, the deadline date is changed when saving it. If I set start and end dates on 01/fev/2016, for example, start date will be stored properly, and deadline will be 31/jan/2016, just as described above.

That makes the Project Management tool completely usefull, because users cannot keep track of their deadlines properly.

Everything is working fine with CRM tasks.

It is installed on a fresh installation of Ubuntu 15.10.

Has anyone ever had any problems like that? Is there any solution?

Thank you all for your help!
ghribas
 
Posts: 3
Joined: Mon Feb 01, 2016 11:59 am

Re: Problems with DATE fields (saves with a day earlier)

Postby Dean » Wed Feb 03, 2016 11:52 am

Hello,

Could you please specify the region settings on the portal and the server itself?
Dean
 
Posts: 700
Joined: Tue Sep 30, 2014 11:04 am

Re: Problems with DATE fields (saves with a day earlier)

Postby ghribas » Thu Feb 04, 2016 5:06 pm

Dean wrote:Hello,

Could you please specify the region settings on the portal and the server itself?


Hi Dean! Thanks for your reply.

These are the region/locale setting on Onlyoffice:

Code: Select all
================================
ONLY OFFICE
================================
Language: Portuguese (Brazil)
Timezone: (UTC-03:00) America/Sao_Paulo


And these are the region/locale setting on the server:
Code: Select all
================================
SERVER: UBUNTU 15.10 - date and time on the server are OK
================================
ssh:~# date
   Thu Feb  4 14:55:50 BRST 2016
ssh:~# locale
   LANG=en_US.UTF-8
   LANGUAGE=
   LC_CTYPE="en_US.UTF-8"
   LC_NUMERIC="en_US.UTF-8"
   LC_TIME="en_US.UTF-8"
   LC_COLLATE="en_US.UTF-8"
   LC_MONETARY="en_US.UTF-8"
   LC_MESSAGES="en_US.UTF-8"
   LC_PAPER="en_US.UTF-8"
   LC_NAME="en_US.UTF-8"
   LC_ADDRESS="en_US.UTF-8"
   LC_TELEPHONE="en_US.UTF-8"
   LC_MEASUREMENT="en_US.UTF-8"
   LC_IDENTIFICATION="en_US.UTF-8"
   LC_ALL=
ssh:~# locale -a
   C
   C.UTF-8
   en_US.utf8
   POSIX
ghribas
 
Posts: 3
Joined: Mon Feb 01, 2016 11:59 am

Re: Problems with DATE fields (saves with a day earlier)

Postby Dean » Mon Feb 08, 2016 7:57 am

Hello,

As we can see the time & date settings on the portal do not correspond the BRST. As a temporary fix please change your portal time & date settings to UTC -02.00.

The problem is that ONLYOFFICE doesn't have3 a setting for the Winter-Summer timezone. We shall send it to our developers team.
Dean
 
Posts: 700
Joined: Tue Sep 30, 2014 11:04 am

Re: Problems with DATE fields (saves with a day earlier)

Postby ghribas » Mon Feb 08, 2016 1:58 pm

Dean wrote:Hello,

As we can see the time & date settings on the portal do not correspond the BRST. As a temporary fix please change your portal time & date settings to UTC -02.00.

The problem is that ONLYOFFICE doesn't have3 a setting for the Winter-Summer timezone. We shall send it to our developers team.


Hi Dean! You are right, the timezone was the problem.
I had to change the timezone to UTC-2 on both the portal and the server to get it working. I hope you guys get a fix soon.
Thank you very much!
Regards, Guilherme.
ghribas
 
Posts: 3
Joined: Mon Feb 01, 2016 11:59 am

Re: Problems with DATE fields (saves with a day earlier)

Postby riverdawn » Thu Jun 14, 2018 9:35 pm

Hello,

Onlyoffice is still having timezone issues, apparently.

If I import my Calendar to google calendar, my appointments show up in UTC, ignoring DST.

Is this fixed at all?

Thanks,
riverdawn
 
Posts: 3
Joined: Fri Jun 01, 2018 1:11 pm


Return to Miscellaneous

Who is online

Users browsing this forum: No registered users and 2 guests