Try the fastest and simplest way to install ONLYOFFICE

OnlyOffice settings not finding up Sphinx.

Re: OnlyOffice settings not finding up Sphinx.

Postby nommaz » Sat Dec 31, 2016 11:10 am

I have followed the instructions, I have two processes:

onlyoff+ 5154 1 0 10:57 ? 00:00:00 /usr/bin/searchd --config /var/www/onlyoffice/Services/TeamLabSvc/sphinx-min.conf.in
onlyoff+ 5155 5154 0 10:57 ? 00:00:00 /usr/bin/searchd --config /var/www/onlyoffice/Services/TeamLabSvc/sphinx-min.conf.in

I checked the indexes and see that they are populated by doing "mysql --port 5906 --user root --database onlyoffice"

However there is no content directly in the database that can help with free text search, so I figure the search hits will come from these two entries under sphinx-min.conf.in

index files_file_main : main
{
source = files_file_main
path = /var/www/onlyoffice/Data/Index/files/file/main
}

index files_file_delta : main
{
source = files_file_delta
path = /var/www/onlyoffice/Data/Index/files/file/delta
}

In that directory i see

-rw-r--r-- 1 onlyoffice onlyoffice 5737 Dec 31 10:00 main.spi which I assume to be the first one and
-rw-r--r-- 1 onlyoffice onlyoffice 1303 Dec 31 10:00 main.spd which must be the delta.

I have very few files in the site but still these indexes are too small to hold the content. When I tried to read them I can see that they only hold search text for file names not file content.

I can search for file names (filter function) but not the content, also the Integration->Sphinx Settings test fails. Would also be helpful to know what it checks exactly.

Also more information about where the file content is held may help troubleshoot the issue better.

Thanks!
Vedat
nommaz
 
Posts: 30
Joined: Thu Dec 08, 2016 6:46 am

Re: OnlyOffice settings not finding up Sphinx.

Postby Maxim » Tue Jan 03, 2017 8:23 am

Hi nommaz!
I've sent your issue to our developers. Latter i will answer you. Please wait a while.
Maxim
 
Posts: 379
Joined: Tue Oct 11, 2016 2:34 pm

Re: OnlyOffice settings not finding up Sphinx.

Postby 1337hium » Tue Jan 03, 2017 9:03 am

Maxim wrote:
1337hium wrote:Where are the instructions to install/config Sphinx on Ubuntu?

Hello!
To set up full text search in Community Server under Ubuntu you will need to do the following:
1. Install the latest version of sphinx. Read more details here on how to do that.
2. Stop the sphinxsearch service using the following command:
Code: Select all
sudo service sphinxsearch stop

3. Restart the onlyofficeIndex service:
Code: Select all
sudo service onlyofficeIndex restart

Automatic installation is not supported for Ubuntu due to the installator security restrictions.
This tutorial is here for Ubuntu and here for Windows.


Hi!

I did this, but there is only the default config at /etc/sphinxsearch/sphinx.conf

How i get the right config?
1337hium
 
Posts: 10
Joined: Wed Dec 30, 2015 8:56 am

Re: OnlyOffice settings not finding up Sphinx.

Postby nommaz » Sat Jan 07, 2017 5:54 pm

Hi Maxim

 The online write up references 2.2.10 but my system shows 2.2.11. According to release notes there doesnt seem to be anything that should affect compatibility but wanted to bring it up anyways.
nommaz
 
Posts: 30
Joined: Thu Dec 08, 2016 6:46 am

Re: OnlyOffice settings not finding up Sphinx.

Postby nommaz » Tue Jan 17, 2017 6:46 pm

Maxim wrote:Hi nommaz!
I've sent your issue to our developers. Latter i will answer you. Please wait a while.


Hi Maxim. Waiting for some feedback. Thanks.
nommaz
 
Posts: 30
Joined: Thu Dec 08, 2016 6:46 am

Previous

Return to Miscellaneous

Who is online

Users browsing this forum: Google [Bot] and 1 guest

cron