Try the fastest and simplest way to install ONLYOFFICE

OnlyOffice settings not finding up Sphinx.

Re: OnlyOffice settings not finding up Sphinx.

Postby Dean » Tue Feb 09, 2016 8:16 am

Hello,

Yes, it was. Would you mind checking out the version of ONLYOFFICE installed?
Dean
 
Posts: 700
Joined: Tue Sep 30, 2014 11:04 am

Re: OnlyOffice settings not finding up Sphinx.

Postby mrman » Wed Feb 10, 2016 5:43 am

This now works on a Standalone version. However, not on docker.

Version 8.7.1 from Docker.

As Sphinx is installed on the host which is running a docker version of onlyoffice (https://github.com/ONLYOFFICE/Docker-CommunityServer), could this be causing the problem?

Can you provide the instructions on how to run Sphinx on a host and connect it to docker? Then I can verify if my setup is correct.

I'm using the current config for docker

sudo docker run -i -t -d -p 443:443 -p 9306:9306 --restart=always -v /opt/onlyoffice/Logs:/var/log/onlyoffice -v /opt/onlyoffice/Data:/var/www/onlyoffice/Data -v /opt/onlyoffice/MySQL:/var/lib/mysql -v /opt/onlyoffice/WebStudio:/var/www/onlyoffice/WebStudio onlyoffice/communityserver


I've tried the logging into Docker instance and running the following commands:
sudo service onlyofficeIndex stop
sudo rm -rf /var/www/onlyoffice/Data/Index/*
mysql -u root -p
use onlyoffice;
truncate table webstudio_index;
exit;

Then I've restarted the host and only 443 is open 9306 remains closed.
mrman
 
Posts: 52
Joined: Sun Oct 25, 2015 12:15 pm

Re: OnlyOffice settings not finding up Sphinx.

Postby mrman » Tue Feb 16, 2016 2:47 am

Everytime I restart the host I have to clear all the settings in docker... Any ideas why? Then it stops working after 3 minutes.
mrman
 
Posts: 52
Joined: Sun Oct 25, 2015 12:15 pm

Re: OnlyOffice settings not finding up Sphinx.

Postby mrman » Thu Apr 21, 2016 1:16 am

Is there an update on this, as this key feature of searching is not working we are considering going to Sharepoint...
mrman
 
Posts: 52
Joined: Sun Oct 25, 2015 12:15 pm

Re: OnlyOffice settings not finding up Sphinx.

Postby mrman » Wed May 04, 2016 3:08 am

Any updates... it's been 3 months....
mrman
 
Posts: 52
Joined: Sun Oct 25, 2015 12:15 pm

Re: OnlyOffice settings not finding up Sphinx.

Postby Dean » Thu May 05, 2016 12:25 pm

It is working in 8.7. We've checked it. There may be some problems in starting the onlyofficeIndex service but it can be restarted. If it doesn't help, we need logs from the /var/log/onlyoffice/svcIndex.$date.log and /var/log/sphinxsearch.
Dean
 
Posts: 700
Joined: Tue Sep 30, 2014 11:04 am

Re: OnlyOffice settings not finding up Sphinx.

Postby mrman » Mon Jul 18, 2016 1:27 am

Confirmed working in 8.9
mrman
 
Posts: 52
Joined: Sun Oct 25, 2015 12:15 pm

Re: OnlyOffice settings not finding up Sphinx.

Postby nommaz » Tue Dec 20, 2016 3:29 pm

Hello new user here!

I couldnt find instructions for sphinx install on standalone.

Yes there is a small bit under troubleshooting but the sphinx.conf resulting with default install surely must be changed to match onlyoffice right?

I saw https://github.com/ONLYOFFICE/Community ... in.conf.in

Tried to replace sphinx.conf with it by supplying database credentials, but had no idea for %LOG_PATH% or other var. Or even if I should be doing this in the first place.
nommaz
 
Posts: 30
Joined: Thu Dec 08, 2016 6:46 am

Re: OnlyOffice settings not finding up Sphinx.

Postby 1337hium » Tue Dec 27, 2016 8:29 am

nommaz wrote:Hello new user here!

I couldnt find instructions for sphinx install on standalone.

Yes there is a small bit under troubleshooting but the sphinx.conf resulting with default install surely must be changed to match onlyoffice right?

I saw https://github.com/ONLYOFFICE/Community ... in.conf.in

Tried to replace sphinx.conf with it by supplying database credentials, but had no idea for %LOG_PATH% or other var. Or even if I should be doing this in the first place.



Same Problem here. Where are the instructions to install/config Sphinx on Ubuntu?
1337hium
 
Posts: 10
Joined: Wed Dec 30, 2015 8:56 am

Re: OnlyOffice settings not finding up Sphinx.

Postby Maxim » Wed Dec 28, 2016 12:21 pm

1337hium wrote:Where are the instructions to install/config Sphinx on Ubuntu?

Hello!
To set up full text search in Community Server under Ubuntu you will need to do the following:
1. Install the latest version of sphinx. Read more details here on how to do that.
2. Stop the sphinxsearch service using the following command:
Code: Select all
sudo service sphinxsearch stop

3. Restart the onlyofficeIndex service:
Code: Select all
sudo service onlyofficeIndex restart

Automatic installation is not supported for Ubuntu due to the installator security restrictions.
This tutorial is here for Ubuntu and here for Windows.
Maxim
 
Posts: 666
Joined: Tue Oct 11, 2016 2:34 pm

PreviousNext

Return to Miscellaneous

Who is online

Users browsing this forum: No registered users and 2 guests