Try the fastest and simplest way to install ONLYOFFICE

Error when configuring Owncloud with OnlyOffice API hostname

Issues during installation, usage and configuring

Error when configuring Owncloud with OnlyOffice API hostname

Postby Gobille » Fri Nov 02, 2018 4:17 pm

Hi,

my problem is simple (maybe) :

I have installed Owncloud on an Debian Server with Onlyoffice from scratch on the same virtual machine (no Docker, no .OVA image file)

Apache run for Owncloud, on port 80 at this url http://192.168.1.1 and OnlyOffice with NGinx, on port 81 at this url http://192.168.1.1:81
Welcome page are ok for both

API intégration is ok. All play well :) I can create docs, modify, etc.

Now i try to use a hostname instead of IP address. http://owncloud.myweb.com is Ok. http://owncloud.myweb.com:81 is ok and i arrive on OnlyOffice welcome page
But API integration won't play, i've got this error : Error when trying to connect (Bad Request or timeout error)

And, for sure, if i try to put the IP address instead of my web name : Error when trying to connect (Error occurred in the document service: Error while downloading the document file to be converted.) I think this is because Owncloud is called by the hostname and not the IP address and the link can't be established between them.

Where can I change a setting for the link to be ok with the name of the machine instead of IP address ?

After, I have tried to pass the websites on SSL with my wildcard certificate. Success for Owncloud, and success for Onlyoffice (Apache on 443 port , NGinx on 444 port), but same probleme for the link between them on API configuration.

Thanks for help.
Gobille
 
Posts: 3
Joined: Fri Nov 02, 2018 3:55 pm

Re: Error when configuring Owncloud with OnlyOffice API host

Postby Carl » Wed Nov 07, 2018 7:26 am

Hello,

Please specify the version of Document Server.
Also send us Document Server logs: /var/log/onlyoffice/documentserver/
Carl
 
Posts: 87
Joined: Thu Apr 12, 2018 10:00 am

Re: Error when configuring Owncloud with OnlyOffice API host

Postby Gobille » Wed Nov 14, 2018 8:00 am

Hello,

I'll send it asap :)
Gobille
 
Posts: 3
Joined: Fri Nov 02, 2018 3:55 pm

Re: Error when configuring Owncloud with OnlyOffice API host

Postby Gobille » Sat Nov 17, 2018 8:54 pm

Hi,

Ubuntu server 14.04, and on the same machine :
Owncloud 10.0.10 installed on Apache, with SSL (wildcard certificate) port 443
OnlyOffice 5.2 installed on NGinx,with SSL (wildcard certificate) port 444

I haven't any error in Onlyoffice logs.
But in Owncloud.log i have this error when i try to put https://mywebsite.com:444 in "Document Editing Service address" to declare my onlyoffice server :

{"reqId":"01lzUkOUDFWK3xh5fp2","level":3, "time":"2018-11-17T20:32:28+00:00","remoteAddr":"192.168.1.45","user":"owncloud-admin","app":"onlyoffice","method":"PUT","url":"\/index.php\/apps\/onlyoffice\/ajax\/settings","message":"HealthcheckRequest on check error: Bad request or timeout error"}

I call my Owncloud Webpage by his url https://mywebsite.com


If i try with IP address, calling owncloud webpage by https://192.168.1.45 and put the onlyoffice parameter with https://192.168.1.45:444, that works.

When i see the error, it seems to be stuck on the IP address, but don't interrogate then complete url. Where can i change this parameter ?
Gobille
 
Posts: 3
Joined: Fri Nov 02, 2018 3:55 pm


Return to ownCloud/Nextcloud ONLYOFFICE integration app

Who is online

Users browsing this forum: No registered users and 1 guest