Try the fastest and simplest way to install ONLYOFFICE

Onlyoffice/Nextcloud with one public FQDN

Issues during installation, usage and configuring

Onlyoffice/Nextcloud with one public FQDN

Postby jafinn » Wed Oct 18, 2017 4:08 pm

Hi

I have set up onlyoffice documentserver in a docker container with SSL enabled according to the instructions on github.

I have set up Nextcloud on a different server according to the official documentation.

If I'm on my LAN everything works as expected and I can edit documents fine so I think I'm on the right track. The issue is accessing/editing documents outside my LAN. According to the documentation here you can access the integrated server on the public address as long as you set it up correctly. When I go to my public address I just get the "Documentserver is running" page.


When entering the URLs in Nextcloud I get a "Bad request or timeout" but I'm not sure what's wrong, this is how I set it up

Image

Any tips/tricks are highly appreciated:)
jafinn
 
Posts: 5
Joined: Wed Oct 18, 2017 3:22 pm

Re: Onlyoffice/Nextcloud with one public FQDN

Postby Maxim » Mon Oct 23, 2017 11:59 am

Hello jafinn!
It should work!
Is there a chance to see logs?
Is it the same https://<PUBLIC IP> from LAN or from extern?
Maxim
 
Posts: 1162
Joined: Tue Oct 11, 2016 2:34 pm

Re: Onlyoffice/Nextcloud with one public FQDN

Postby jafinn » Sun Oct 29, 2017 10:44 pm

Hi

Apologies for the late reply, have been away for work.

I'd be happy to provide logs if you could point me in the right direction. This is what I get from the logging section in Nextcloud when trying to connect:

Code: Select all
Level   App   Message   Time
Error   onlyoffice   CommandRequest on check error: Bad Request or timeout error   2017-10-29T23:32:22+0100
Error   PHP   file_get_contents(https://onlyoffice.box/coauthoring/CommandService.ashx): failed to open stream: operation failed at /usr/share/nextcloud/apps/onlyoffice/lib/documentservice.php#351   2017-10-29T23:32:22+0100
Error   PHP   file_get_contents(): Failed to enable crypto at /usr/share/nextcloud/apps/onlyoffice/lib/documentservice.php#351   2017-10-29T23:32:22+0100
Error   PHP   file_get_contents(): SSL operation failed with code 1. OpenSSL Error messages: error:14090086:SSL routines:SSL3_GET_SERVER_CERTIFICATE:certificate verify failed at /usr/share/nextcloud/apps/onlyoffice/lib/documentservice.php#351   2017-10-29T23:32:22+0100


I'm not sure if I understand your last question. When I'm outside my LAN and use my public IP I only get the "Documentserver is running" page (as ports 80,443 is forwarded to the documentserver). When I'm inside my LAN, I get the same page when accessing the documentserver but then I can go to my nextcloud server and editing documents works from there.
jafinn
 
Posts: 5
Joined: Wed Oct 18, 2017 3:22 pm

Re: Onlyoffice/Nextcloud with one public FQDN

Postby Maxim » Mon Oct 30, 2017 6:39 am

Hello jafinn!
I mean that when you are outside your LAN or inside you LAN you type in the browser to get the Document Server the same https://<PUBLIC IP> for both variants?
There is an error with SSL "certificate verify failed". First of all i would disable SSL on both servers to check connections between servers just to be sure that everything is ok and works correctly.
Maxim
 
Posts: 1162
Joined: Tue Oct 11, 2016 2:34 pm

Re: Onlyoffice/Nextcloud with one public FQDN

Postby jafinn » Mon Oct 30, 2017 7:26 am

I get the same result using my external IP from inside my LAN, I just get the "Document server is running" front page.

The certificates can't be verified because they are self signed. I can try disabling SSL and see if that does anything but like I said if I go to https://nextcloud.localIP inside my LAN, it works. I feel like I'm missing something as according to the schematic in the installation instructions, only the onlyoffice IP should be exposed to the internet but there is no way of logging in to nextcloud if I go to https://onlyoffice.localIP. Only the "Document server is running" page. I feel like there should be a reverse proxy or something running for this to work?
jafinn
 
Posts: 5
Joined: Wed Oct 18, 2017 3:22 pm

Re: Onlyoffice/Nextcloud with one public FQDN

Postby jafinn » Mon Oct 30, 2017 9:08 am

Ok, I did a quick fresh install on two VMs without SSL, I don't get any error messages when connecting to the documentserver from nextcloud. Document editing works fine. I also tried going through the manual installation instead of running the docker image which also works fine.

But, I still only get the "Document server is running" frontpage.. What am I missing?

This clearly says to forward your external IP to the document server
Image
jafinn
 
Posts: 5
Joined: Wed Oct 18, 2017 3:22 pm

Re: Onlyoffice/Nextcloud with one public FQDN

Postby Maxim » Mon Oct 30, 2017 12:02 pm

Hello jafinn!
I hope it will help you.
Please open the config file /nextcloud/config/config.php. (/var/www/nextcloud/config/config.php)
And add the following section:
Code: Select all
'onlyoffice' =>
  array (
    'verify_peer_off' => TRUE,
  )]
Maxim
 
Posts: 1162
Joined: Tue Oct 11, 2016 2:34 pm

Re: Onlyoffice/Nextcloud with one public FQDN

Postby jafinn » Wed Nov 01, 2017 7:33 am

I've tried adding:

Code: Select all
  'onlyoffice' =>
  array (
    'verify_peer_off' => TRUE,
  )


but this doesn't seem to do anything. I don't get anything in the log and it connects fine. I still can't use the documentserver from my external IP.
jafinn
 
Posts: 5
Joined: Wed Oct 18, 2017 3:22 pm

Re: Onlyoffice/Nextcloud with one public FQDN

Postby Maxim » Fri Nov 10, 2017 7:55 am

Hello jafinn!
Have solved the issue?
Maxim
 
Posts: 1162
Joined: Tue Oct 11, 2016 2:34 pm


Return to ownCloud/Nextcloud ONLYOFFICE integration app

Who is online

Users browsing this forum: No registered users and 1 guest