Try the fastest and simplest way to install ONLYOFFICE

Document server working, but opening documents hangs

Issues during installation, usage and configuring

Document server working, but opening documents hangs

Postby Odinbot » Fri Jun 09, 2017 5:18 pm

Hello all,

I have Nextcloud 12 setup in 1 VM with SSL, and OO Document Server latest version, I think 4.3.5. When I visit my FQDN for my OnlyOffice server, I receive the "Document Server is running" message. However, when trying to open a document, spreadsheet, etc. from Nextcloud, it will open the new tab and load the https://<myserver>/apps/onlyoffice/<ID> URL and it loads the nextcloud header page, but the rest is blank.

I've looked at all the logs I can and it seems that something is wrong based on entries:
[2017-06-09 12:07:44.943] [ERROR] nodeJS - [AMQP] Error: connect ECONNREFUSED 127.0.0.1:5672
at Object.exports._errnoException (util.js:1018:11)
at exports._exceptionWithHostPort (util.js:1041:20)
at TCPConnectWrap.afterConnect [as oncomplete] (net.js:1086:14)
[2017-06-09 12:07:45.948] [ERROR] nodeJS - [AMQP] Error: connect ECONNREFUSED 127.0.0.1:5672
at Object.exports._errnoException (util.js:1018:11)
at exports._exceptionWithHostPort (util.js:1041:20)
at TCPConnectWrap.afterConnect [as oncomplete] (net.js:1086:14)
[2017-06-09 12:07:47.162] [WARN] nodeJS - Express server listening on port 8000 in production-linux mode

However, it says the document server is working when I visit my FQDN, and otherwise all services appear to be running fine: nginx, rabbitmq-server, redis, postgresql all are running. Any idea what could be causing documents not to load?

I do have the option to convert .odt files to .docx files in the Nextcloud interface, and that works. The new file is created, but when clicking on it (or any file that opens OnlyOffice), the new browser tab opens with the Nextcloud header bar, and the rest is blank. I never get the "ONLYOFFICE could not be opened. Please contact your system administrator error" - I was previously, but going with fully qualified names and adding SSL removed that error.

Thanks in advance for any replies, and I'll try to provide logs/screenshots whenever requested, just wasn't sure what to put in this first post.
Odinbot
 
Posts: 2
Joined: Fri Jun 09, 2017 4:38 pm

Re: Document server working, but opening documents hangs

Postby Maxim » Tue Jun 13, 2017 10:25 am

Hello Odinbot!
1 Specify please Onlyoffice app version you are using, the last one is 1.0.5
2 While saving process of editor's address on the page of Nextcloud connection what message did you get - Connected?
3 Do you notice any errors in browser's console while opening editor's page?
4 SSL? If you try to open in the browser https://<YourDocumentServer>/web-apps/apps/api/documents/api.js what you get?
Maxim
 
Posts: 1170
Joined: Tue Oct 11, 2016 2:34 pm

Re: Document server working, but opening documents hangs

Postby Odinbot » Tue Jun 13, 2017 2:01 pm

Thank for approving my post and responding!

Let's get to the answers:
1 Specify please Onlyoffice app version you are using, the last one is 1.0.5
- I am using 1.0.5 of the OnlyOffice app within Nextcloud
2 While saving process of editor's address on the page of Nextcloud connection what message did you get - Connected?
- Yes, when testing my connection from the App Settings page within the Nextcloud settings, it shows successful connection
3 Do you notice any errors in browser's console while opening editor's page?
- Yes, thank you! I've been scouring logs on both sides and haven't been able to find an error for days, and now I see something is getting blocked due to X-Frames option set to deny! Any ideas on how to fix this while not allowing global x-frame deny? I'm not super educated on the x-frames-option, but I do see it most often listed as blocked for public websites such as the one I am working on.

The error I am getting in Console:
Refused to display 'https://onlyoffice.mydomain.com/2017-06-02-12-46/web-apps/apps/presentat…dc=2017-06-02-12-46&lang=en&customer=ONLYOFFICE&frameEditorId=iframeEditor' in a frame because it set 'X-Frame-Options' to 'deny'.
onlyoffice.mydomain.com/2017-06-02-12-46/web-apps/apps/presentationedito…dc=2017-06-02-12-46&lang=en&customer=ONLYOFFICE&frameEditorId=iframeEditor Failed to load resource: net::ERR_BLOCKED_BY_RESPONSE


4 SSL? If you try to open in the browser https://<YourDocumentServer>/web-apps/apps/api/documents/api.js what you get?
- I do have SSL setup on both Nextcloud and Onlyoffice, and when I visit that page I get a starts with:

/**
* Copyright (c) Ascensio System SIA 2013. All rights reserved
*
* http://www.onlyoffice.com
*/

;(function(DocsAPI, window, document, undefined) {



And ends with:
}
}
return dest;
}

})(window.DocsAPI = window.DocsAPI || {}, window, document);
Odinbot
 
Posts: 2
Joined: Fri Jun 09, 2017 4:38 pm

Re: Document server working, but opening documents hangs

Postby Maxim » Wed Jun 14, 2017 8:59 am

Hello Odinbot!
a frame because it set 'X-Frame-Options' to 'deny'

You should set X-Frame-Options: ALLOW-FROM https://nextcloud.mydomain.com/ or remove X-Frame-Options.
Maxim
 
Posts: 1170
Joined: Tue Oct 11, 2016 2:34 pm


Return to ownCloud/Nextcloud ONLYOFFICE integration app

Who is online

Users browsing this forum: No registered users and 1 guest