Try the fastest and simplest way to install ONLYOFFICE

WebDav Move/Copy To Errors

Questions/problems on Docker

WebDav Move/Copy To Errors

Postby Altair » Fri Jul 15, 2016 7:05 pm

Hello,

I am attempting to Move/Copy content from an Alfresco DRM to OnlyOffice and am running into errors when attempting to Move/Copy entire folders with content.
I am using Webdav to connect and am able to successfully access the files (get them to appear in OnlyOffice).

I don't encounter errors when trying to move individual files or groups of individual files, only folders containing subfolders/files.

When selecting a folder and using the Move or Copy To feature, the following error is displayed and the files fail to move: Object reference not set to an instance of an object

I am trying to move the folders & files from the Webdav connection to the Common Documents area.

Oddly, the folder and any subfolder structure gets created, but the files fail to copy over with the folders. I have to go back into the Webdav folders and select the individual files to copy to the Common Documents folder structure.

The web log shows this as the error message:
2016-07-15 18:53:35,140 ERROR [Threadpool worker] ASC.Files - Object reference not set to an instance of an object
System.NullReferenceException: Object reference not set to an instance of an object
at ASC.Files.Core.Data.SecurityDao.GetPureShareRecords (ASC.Files.Core.FileEntry[] entries) <0x414fbf20 + 0x00289> in <filename unknown>:0
at ASC.Files.Thirdparty.ProviderDao.ProviderDaoBase.PerformCrossDaoFileCopy (System.Object fromFileId, System.Object toFolderId, Boolean deleteSourceFile) <0x415fe990 + 0x00197> in <filename unknown>:0
at ASC.Files.Thirdparty.ProviderDao.ProviderDaoBase.PerformCrossDaoFolderCopy (System.Object fromFolderId, System.Object toRootFolderId, Boolean deleteSourceFolder) <0x415fc920 + 0x00427> in <filename unknown>:0
at ASC.Files.Thirdparty.ProviderDao.ProviderFolderDao.CopyFolder (System.Object folderId, System.Object toFolderId) <0x415fc740 + 0x0004f> in <filename unknown>:0
at ASC.Web.Files.Services.WCFService.FileOperations.FileMoveCopyOperation.MoveOrCopyFolders (ICollection folderIds, ASC.Files.Core.Folder toFolder, Boolean copy) <0x415fae10 + 0x004a2> in <filename unknown>:0

Any help as to how I can fix this is much appreciated.

Thank you.
Altair
 
Posts: 1
Joined: Fri Jul 15, 2016 6:44 pm

Return to Docker Version

Who is online

Users browsing this forum: Google [Bot] and 2 guests