Try the fastest and simplest way to install ONLYOFFICE

Getting set up

Questions/problems on Docker

Getting set up

Postby robertotomas » Tue Sep 26, 2017 10:10 pm

I'm having trouble with our install of onlyoffice at work: I'm supposed to create a plugin with the frontend document editor that will allow rich user interfaces on the webpage containing the document editor to insert text into a document.

I thought that I had to install a plugin to a folder in the documentserver called "sdkjs-plugins" .. that folder didn't exist, I had to create it. after doing that and restarting, I see no signs of the plugin having loaded or failed.

Since I'm having trouble with our server install, I decided to do a clean install on my mac. I went the docker way.

This seems like everything is okay:
Code: Select all
Roberts-MBP:~ robertotomas$ sudo docker run -i -t -d -p 8008:80 --restart=always     -v /Volumes/app/onlyoffice/DocumentServer/logs:/var/log/onlyoffice      -v /Volumes/app/onlyoffice/DocumentServer/data:/var/www/onlyoffice/Data      -v /Volumes/app/onlyoffice/DocumentServer/lib:/var/lib/onlyoffice     -v /Volumes/app/onlyoffice/DocumentServer/db:/var/lib/postgresql  onlyoffice/documentserver
af13924e9ab7e84b9c3583714a2e645a3ae6b3532bd09b751948ba26f5dc4f35
Roberts-MBP:~ robertotomas$ docker ps
CONTAINER ID        IMAGE                       COMMAND                  CREATED             STATUS              PORTS                           NAMES
af13924e9ab7        onlyoffice/documentserver   "/bin/sh -c 'bash ..."   4 seconds ago       Up 3 seconds        443/tcp, 0.0.0.0:8008->80/tcp   angry_noether

But when I try to hit localhost:8008 it doesn't load:
This page isn’t working

localhost didn’t send any data.
ERR_EMPTY_RESPONSE

The 8000's are open, for example, the test web server I set up to eventually run document Editor in is running on 8080 and is reachable. Further, if I run `docker run -d -p 80:80 --name webserver nginx` I get an nginx response on localhost:80

What am I missing?

Also, can someone help me understand the next step? How what is the proper way to install and load the onlyoffice document editor in my node webserver?
robertotomas
 
Posts: 17
Joined: Thu Aug 31, 2017 4:05 pm

Re: Getting set up

Postby Maxim » Wed Sep 27, 2017 12:46 pm

Hello robertotomas!
We have installed the Document Server successfully on Mac just now but without Volumes and it works perfect. Please try not to map folders to Volumes.
Maxim
 
Posts: 1072
Joined: Tue Oct 11, 2016 2:34 pm

Re: Getting set up

Postby robertotomas » Wed Sep 27, 2017 1:30 pm

@Maxim I created those directories and ensured they were ugo_+rwx ... why would it matter where it is mounted to? The documentation even says you can change the directories
robertotomas
 
Posts: 17
Joined: Thu Aug 31, 2017 4:05 pm

Re: Getting set up

Postby robertotomas » Wed Sep 27, 2017 1:37 pm

Thank you I have it working. I don't understand why it must be mounted to /app .. but that does work.
robertotomas
 
Posts: 17
Joined: Thu Aug 31, 2017 4:05 pm

Re: Getting set up

Postby Maxim » Thu Sep 28, 2017 11:17 am

Hello robertotomas!
You are always welcome!
Maxim
 
Posts: 1072
Joined: Tue Oct 11, 2016 2:34 pm


Return to Docker Version

Who is online

Users browsing this forum: No registered users and 1 guest