Page 1 of 1

have to setup docker install again after backup

PostPosted: Fri Sep 08, 2017 12:09 am
by zwnk
Hi there,

i setup the ce with docker on windows 10 pro and it is running well. But now i have the problem that i have to setup up the ce again via webinterface after i stopped the servers to update docker.
The same happend to me 2 weeks ago after stopping the container to backup the data.
Can someone help me to prevent that issue?

Cheers

Re: have to setup docker install again after backup

PostPosted: Fri Sep 08, 2017 6:42 am
by Maxim
Hello zwnk!
Please specify did you installed on VM machine?
You can start docker containers again
Code: Select all
docker ps

it shows containers
Code: Select all
docker start [OPTIONS] CONTAINER [CONTAINER...]

Re: have to setup docker install again after backup

PostPosted: Fri Sep 08, 2017 11:38 am
by zwnk
thank you but i'm well aware of that.
i use windows 10 pro with docker ce Version 17.06.2-ce-win27 (13194)

the docker container were stopped and started. I did not create a new container nor reloaded the image.

Code: Select all
Y:\>docker ps -a
CONTAINER ID        IMAGE                        COMMAND                  CREATED             STATUS                        PORTS               NAMES
cc92a3331bde        onlyoffice/communityserver   "/usr/bin/dumb-ini..."   2 weeks ago         Exited (143) 16 seconds ago                       onlyoffice-community-server
9546cb834bad        onlyoffice/mailserver        "/bin/sh -c 'expor..."   2 weeks ago         Exited (137) 6 seconds ago                        onlyoffice-mail-server
aa549d7dc3e2        onlyoffice/documentserver    "/bin/sh -c 'bash ..."   2 weeks ago         Exited (137) 6 seconds ago                        onlyoffice-document-server


as you can see. it is a container created 2 weeks ago.

Re: have to setup docker install again after backup

PostPosted: Fri Sep 08, 2017 11:43 am
by zwnk
the docker commands i used to setup the container:

Code: Select all
docker network create --driver bridge onlyoffice

docker run --net onlyoffice -i -t -d --restart=always --name onlyoffice-document-server ^
   -v f:/ONLYOFFICE/DocumentServer/data:/var/www/onlyoffice/Data ^
   -v f:/ONLYOFFICE/DocumentServer/logs:/var/log/onlyoffice ^
   onlyoffice/documentserver

docker run --net onlyoffice --privileged -i -t -d --restart=always --name onlyoffice-mail-server ^
   -p 25:25 -p 143:143 -p 587:587 ^
   -v f:/ONLYOFFICE/MailServer/data:/var/vmail ^
   -v f:/ONLYOFFICE/MailServer/data/certs:/etc/pki/tls/mailserver ^
   -v f:/ONLYOFFICE/MailServer/logs:/var/log ^
   -v f:/ONLYOFFICE/MailServer/mysql:/var/lib/mysql ^
   -h mail.dmcl.digimapas.cl ^
   onlyoffice/mailserver


docker run --net onlyoffice -i -t -d --restart=always --name onlyoffice-community-server ^
   -p 80:80 -p 5222:5222 -p 443:443 ^
   -v f:/ONLYOFFICE/CommunityServer/data:/var/www/onlyoffice/Data ^
   -v f:/ONLYOFFICE/CommunityServer/mysql:/var/lib/mysql ^
   -v f:/ONLYOFFICE/CommunityServer/logs:/var/log/onlyoffice ^
   -v f:/ONLYOFFICE/DocumentServer/data:/var/www/onlyoffice/DocumentServerData ^
   -e DOCUMENT_SERVER_PORT_80_TCP_ADDR=onlyoffice-document-server ^
   onlyoffice/communityserver


the batch i use to backup the container data:
Code: Select all
REM stop docker container
docker stop onlyoffice-document-server onlyoffice-mail-server onlyoffice-community-server

REM copy data folder
xcopy /E /Y D:\onlyo y:\backup_onlyoffice

REM start docker container
docker start onlyoffice-document-server onlyoffice-mail-server onlyoffice-community-server

Re: have to setup docker install again after backup

PostPosted: Tue Sep 12, 2017 6:43 am
by Maxim
Hello zwnk!
But now i have the problem that i have to setup up the ce again via webinterface after i stopped the servers to update docker.

Do you mean that the Onlyoffice wizard restarts after stopping container?
Maybe it would be better to install Community Edition using script where all needed parametrs included and work correctly.

Re: have to setup docker install again after backup

PostPosted: Tue Sep 12, 2017 11:58 am
by zwnk
exactly, the webinterface starts the installation wizard again.

Re: have to setup docker install again after backup

PostPosted: Mon Sep 18, 2017 6:19 am
by Maxim
Hello zwnk!
Please show a screenshot of docker containers you have.