Try the fastest and simplest way to install ONLYOFFICE

Installation Issue with Community Server and Document Server

Questions/problems on Docker

Installation Issue with Community Server and Document Server

Postby ic57369k » Sun Jun 25, 2017 7:36 am

Hi.
Using Document and Community Server on Ubuntu 16.04 with docker.
Using nginx webserver and mysql 7 (Latest edition compatible with ubuntu 16.04)
I installed the document and community server with your recommended script

(Not getting installed on Port 80) bGiving following error
docker: Error response from daemon: driver failed programming external connectivity on endpoint onlyoffice-community-server (3ec07ed07eba92a89c86b67a5d93541a785d7ef0f08762c96f4a2b84337e0690): Error starting userland proxy: listen tcp 0.0.0.0:80: bind: address already in use.

So instead I use port 8080 for document server and port 8081 for community server . i use following script

sudo docker run -i -t -d -p 8080:80 --name onlyoffice-document-server onlyoffice/documentserver

sudo docker run -i -t -d -p 8081:80 \
--link onlyoffice-document-server:document_server \
onlyoffice/communityserver

When I open up community server, it opens up fine. No problems so far. N
Now, when I go up the documents link and try and open up any sample document, it opens up the doc editor , but returns an error window saying that "Download Failed". on clicking OK, it redirects to http://be7d60011e0a:8081/products/files/#4 and page returns "Server not found".
I am attaching all relevant screen shots.
I have tried almost everything. Installed, reinstalled. Done every permuation. No luck.
Pl help.
Attachments
error.jpg
Download Failed Error window pops up
error.jpg (77.64 KiB) Viewed 757 times
doc editor.jpg
Doc editor
doc editor.jpg (74.7 KiB) Viewed 757 times
main screen.jpg
Community server http://127.0.0.1:8081
main screen.jpg (102.34 KiB) Viewed 757 times
ic57369k
 
Posts: 17
Joined: Sat Jun 24, 2017 4:19 am

Re: Installation Issue with Community Server and Document Se

Postby Maxim » Mon Jun 26, 2017 6:50 am

Hello ic57369k!
This topic i have locked, i have no reason to reply i suppose.
The problem is that your docker containers (servers) cannot connect to each other for some reason.
The "Download failed" message means that the Document editing service cannot upload the file for editing. The Url for downloading is not accessible.
Why don't you install Community Edition with provided script? Ports?
If you install OnlyOffice using the installation script your docker images will be created with a docker network called something similar to onlyoffice-network and only the container for the community server has a host exposed port. The document server image will be part of the onlyoffice-network and be privately communicating with the community server over the docker network only.
Maxim
 
Posts: 1229
Joined: Tue Oct 11, 2016 2:34 pm

Re: Installation Issue with Community Server and Document Se

Postby ic57369k » Wed Jun 28, 2017 5:17 am

I did try to install using the method given in http://helpcenter.onlyoffice.com/server ... ation.aspx .
however, it returns an error
The following ports must be open: 80
Installtion does not complete.
Also, I have tried all scripts in all permutations provided on your site.
ic57369k
 
Posts: 17
Joined: Sat Jun 24, 2017 4:19 am

Re: Installation Issue with Community Server and Document Se

Postby ic57369k » Wed Jun 28, 2017 6:04 am

I did the following actions
1. Tried using the script as specified by you. But got error " The specified port is already in use- Port 80".
2. Then I uninstalled nginx, because, it had held that port.
3. I then installed the onlyoffice using http://helpcenter.onlyoffice.com/server ... ation.aspx as specified by you. It installed fine with following message
bash opensource-install.sh -ims false
% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
100 32454 100 32454 0 0 38564 0 --:--:-- --:--:-- --:--:-- 38543
157b63ee9347af3e34f2a1fef5201c4a56a481ee0af32615ab1a494db03d0d6c
3ec7959235d5d7327174e9e3da18723e4e108dc5eb702d2fdeba216d71d6091d

Thank you for installing ONLYOFFICE.
In case you have any questions contact us via http://support.onlyoffice.com or visit our forum at http://dev.onlyoffice.org


Now i opened browser http://192.168.43.116. Community Server opened. I logged in. However, again ,when I am opening the sample document, it opens up the link http://192.168.43.116/products/files/do ... x?fileid=2. For a few moments , it says loading. Then again, as I have shown in my previous screen shots , it gives a error popup "Download Failed. Press OK to return to Document List".
I have tried every and any script but no luck.
ic57369k
 
Posts: 17
Joined: Sat Jun 24, 2017 4:19 am

Re: Installation Issue with Community Server and Document Se

Postby Maxim » Wed Jun 28, 2017 6:29 am

Hello ic57369k!
By default if the system is OK it shouldn't happen.
In Settings->Document Service you can change the first 4 Service Addresses to internal ip address of Document Server in the Document Server container. To find out ip address you can use next commands
this command shows containers' ID
Code: Select all
sudo docker ps

this command shows document server containers' ip address
Code: Select all
sudo docker inspect [document server containers' ID]

In the end of the file you will find ip address
Put this ip address into Service Addresses
Document Editing Service Address - looks like http://172.18.0.2/web-apps/apps/api/documents/api.js
Document Command Service Address - looks like http://172.18.0.2/coauthoring/CommandService.ashx
Document Storage Service Address - looks like http://172.18.0.2/FileUploader.ashx
Document Conversion Service Address - looks like http://172.18.0.2/ConvertService.ashx
Maxim
 
Posts: 1229
Joined: Tue Oct 11, 2016 2:34 pm

Re: Installation Issue with Community Server and Document Se

Postby ic57369k » Wed Jun 28, 2017 6:58 am

Sorry to bother you again.
Tried all above.
My docker IP is 172.19.0.2
So, I suitably amended settings and document service IPs related to document server .
Settings were correctly saved.
But again, when I click to access any sample document with a hope of editing it, I get the same error pop-up.
ic57369k
 
Posts: 17
Joined: Sat Jun 24, 2017 4:19 am

Re: Installation Issue with Community Server and Document Se

Postby Maxim » Wed Jun 28, 2017 7:34 am

Hello ic57369k!
I would advise you to install on fresh Ubuntu 16.04. or try to install on another machine with Ubuntu. For some reason Document Server cannot connect to Community Server.
Maxim
 
Posts: 1229
Joined: Tue Oct 11, 2016 2:34 pm

Re: Installation Issue with Community Server and Document Se

Postby ic57369k » Wed Jun 28, 2017 1:05 pm

Thx.
1. I installed ubuntu 16.04 all over again.
2. Installed docker.
3. Installed onlyoffice using script uou provided.
4. Voila! Started working. I could fire up the documents and edit them on the same machine.
5. I got more ambititious. I created two users.
6. Users could access the community server with http://192.168.43.116. Great so far.
7. When users try to access the documents, the process is first of all verry very slow. Too much time. Then finally, comes the message
"ONLYOFFICE™ is not available. Please contact us at support@onlyoffice.com"
8. Now i can access documents from the same machine on which the servers are installed, but cant access from other machines on the network through the web browser.
Thanks and regards in advance.
ic57369k
 
Posts: 17
Joined: Sat Jun 24, 2017 4:19 am

Re: Installation Issue with Community Server and Document Se

Postby ic57369k » Thu Jun 29, 2017 6:42 am

Thx.
1. I installed ubuntu 16.04 all over again.
2. Installed docker.
3. Installed onlyoffice using script uou provided.
4. Voila! Started working. I could fire up the documents and edit them on the same machine.
5. I got more ambititious. I created two users.
6. Users could access the community server with http://192.168.43.116. Great so far.
7. When users try to access the documents, the process is first of all verry very slow. Too much time. Then finally, comes the message
"ONLYOFFICE™ is not available. Please contact us at support@onlyoffice.com"
8. Now i can access documents from the same machine on which the servers are installed, but cant access from other machines on the network through the web browser.
Thanks and regards in advance.
ic57369k
 
Posts: 17
Joined: Sat Jun 24, 2017 4:19 am

Re: Installation Issue with Community Server and Document Se

Postby Maxim » Fri Jun 30, 2017 7:46 am

Hello ic57369k!
Now i can access documents from the same machine on which the servers are installed, but cant access from other machines on the network through the web browser.

You should check your network configuration. In your case requests from user's browser cannot get access to the Document Server.
Maxim
 
Posts: 1229
Joined: Tue Oct 11, 2016 2:34 pm

Next

Return to Docker Version

Who is online

Users browsing this forum: Yahoo [Bot] and 2 guests