Try the fastest and simplest way to install ONLYOFFICE

MAIL option problematic with external server for mail

Questions/problems on Docker

MAIL option problematic with external server for mail

Postby wasp_osa » Wed Jul 11, 2018 3:26 pm

Hello to everyone!
I am just starting to use the OO_CE and all works great, with some small crashes and needs in restart every few days.
however, I have a bigger problem with mail module.

I have an external mail server that is used for website and mail hosting, this server is not under my control and is located on hosting provider.

I have connected the OO_CE to the mail servers via SSL and normal POP (tried both options), the mail is coming to the folder and all works great, Ive opened all the ports etc. for it to go in and out.
however, after sometime Ive noticed that my mail server on hosting is blocking my ip of where the OO_CE is installed, this is after few days or sometimes hours, and I have to change the ip every few days or earlier to get the mail from servers from any of my pcs , because hosting is blocking my ip, they said this is because of too many attempts to fast.

As I understood, that this have happened because of too many connections.. the firewall blocking of my OO_CE ip on mail server.

is there a way to make less connections and mail checking from OO_CE to mail server? so that it would go checking every 15 minutes in change of every 1 min or how often is it now?

thank you in advance!

regards
Alex
wasp_osa
 
Posts: 2
Joined: Wed Jul 11, 2018 3:11 pm

Re: MAIL option problematic with external server for mail

Postby Maxim » Mon Jul 16, 2018 8:22 am

Hello wasp_osa!
Unfortunately but you did not specify your type of Onlyoffice installation. So ut is for Docker
is there a way to make less connections and mail checking from OO_CE to mail server?

1. So you should connect to database and increase delay
By default it is set to 30 seconds (login_delay = 30 sec.)
Code: Select all
update mail_mailbox set login_delay = 300 where address like '%example.com' and is_removed = 0;

For docker version
Code: Select all
docker exec -it onlyoffice-mysql-server mysql -p(MySQL password) --silent -e "use onlyoffice; update mail_mailbox set login_delay = 300 where address like '%example.com' and is_removed = 0;"

Is it possible to configure the scan request time for new messages on the external mail server?

By default, the timeout after processing all the boxes is 10 seconds, in the following example it is increased to 300 seconds.
Code: Select all
docker exec -it onlyoffice-community-server sed -i 's/<add key="mail.check-work-timer-seconds" value="10" \/>/<add key="mail.check-work-timer-seconds" value="300" \/>/g' /var/www/onlyoffice/Services/MailAggregator/ASC.Mail.Aggregator.CollectionService.exe.config && docker exec -it onlyoffice-community-server god restart onlyofficeMailAggregator
Maxim
 
Posts: 1649
Joined: Tue Oct 11, 2016 2:34 pm

Re: MAIL option problematic with external server for mail

Postby wasp_osa » Wed Jul 18, 2018 3:37 pm

Dear Maxim! just came back from the trip, and already implemented the solution you wrote to me earlier! THANK YOU IN ADVANCE if something doesn't work ill write again;-)

regards
AO
wasp_osa
 
Posts: 2
Joined: Wed Jul 11, 2018 3:11 pm

Re: MAIL option problematic with external server for mail

Postby Maxim » Fri Jul 20, 2018 7:08 am

Hello wasp_osa!
I hope it will help you to cut mail connections.
Maxim
 
Posts: 1649
Joined: Tue Oct 11, 2016 2:34 pm


Return to Docker Version

Who is online

Users browsing this forum: No registered users and 4 guests