Try the fastest and simplest way to install ONLYOFFICE

ONLYOFFICE IS NOT AVAILABLE ERROR MESSAGE

Suggestions on Document Server Installation/Functionality

ONLYOFFICE IS NOT AVAILABLE ERROR MESSAGE

Postby ic57369k » Thu Jun 29, 2017 4:39 pm

1 I installed onlyoffice community and document server using docker on ubuntu 16.04
2. Voila! Started working. I could fire up the documents and edit them on the same machine.
3. I got more ambititious. I created two users.
4. Users could access the community server with http://192.168.43.116. Great so far.
5. When users try to access the documents, the process is first of all verry very slow. Too much time. Then finally, comes the message
"ONLYOFFICE™ is not available. Please contact us at support@onlyoffice.com"
6. Now i can access documents from the same machine on which the servers are installed, but cant access from other machines on the network through the web browser.
Thanks and regards in advance.
ic57369k
 
Posts: 17
Joined: Sat Jun 24, 2017 4:19 am

Re: ONLYOFFICE IS NOT AVAILABLE ERROR MESSAGE

Postby Maxim » Fri Jun 30, 2017 6:43 am

Hello ic57369k!
The message "ONLYOFFICE™ is not available" means that Community Server cannot get access to the Document Server.
1 Please specify how did you install Onlyoffice? With provided script? Why is it important? If you install separately Community Server for docker and Document Server for docker then there is no Docker network wich allows communicate them with each other, but when you install with provided script the docker network would be created with all required parametrs.
2 Try to run command
Code: Select all
wget http://192.168.43.116/web-apps/apps/api/documents/api.js

If it's all good you would get next
Code: Select all
Connecting to 192.168.43.116:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 26052 (25K) [application/x-javascript]
Saving to: ‘api.js’

api.js              100%[===================>]  25,44K  --.-KB/s    in 0s

3 run command "sudo docker ps" to check that containers work
Maxim
 
Posts: 1170
Joined: Tue Oct 11, 2016 2:34 pm

Re: ONLYOFFICE IS NOT AVAILABLE ERROR MESSAGE

Postby ic57369k » Fri Jun 30, 2017 8:43 am

The connecting machine is an Android mobile on WiFi. The Server Laptop is also connected on WiFi. The Android mobile has a portable hotspot on which the server laptop connects for access to Internet. So when the DHCP server on android mobile has allocated 192.168.43.116 to the laptop. Now using this mobile phone, if I access the laptop using http://192.168.43.116 on WiFi, it accesses the community server.

Now to try running above wget command on mobile terminal, it successfully shows the following

Connecting to 192.168.43.116(192.168.43.116:80)
api.js 100% 26052 0.00.00 ETA
ic57369k
 
Posts: 17
Joined: Sat Jun 24, 2017 4:19 am

Re: ONLYOFFICE IS NOT AVAILABLE ERROR MESSAGE

Postby ic57369k » Fri Jun 30, 2017 8:45 am

To add to the above, when I put http://192.168.43.116/web-apps/apps/api ... nts/api.js in the web browser of the mobile, it return me the following

404 Not Found
nginx
ic57369k
 
Posts: 17
Joined: Sat Jun 24, 2017 4:19 am

Re: ONLYOFFICE IS NOT AVAILABLE ERROR MESSAGE

Postby ic57369k » Sat Jul 01, 2017 5:51 am

The connecting machine is an Android mobile on WiFi. The Server Laptop is also connected on WiFi. The Android mobile has a portable hotspot on which the server laptop connects for access to Internet. So when the DHCP server on android mobile has allocated 192.168.43.116 to the laptop. Now using this mobile phone, if I access the laptop using http://192.168.43.116 on WiFi, it accesses the community server.

Now to try running above wget command on mobile terminal, it successfully shows the following

Connecting to 192.168.43.116(192.168.43.116:80)
api.js 100% 26052 0.00.00 ETA

To add to the above, when I put http://192.168.43.116/web-apps/apps/api ... nts/api.js in the web browser of the mobile, it return me the following

404 Not Found
nginx

I thought, maybe the WiFi may be creating issues. So I rigged up a simple standalone network.

I got one PC again running ubuntu 16.04.
I connected both the PCs (onlyoffice PC) and client PC to a standalone switch.
I gave onlyoffice PC ethernet port IP 192.168.10.2 and client PC as 192.168.10.3.
I then accessed community server from client PC by putting http://192.168.10.2

I was able to access the community portal and login.
I then went to documents and tried to access the sample document.

It is here again, when I get the ONLY OFFICE IS NOT AVAILABLE error window.
Now ,here there is no network. Just two PCs connected to a simple unmanaged switch ( so no issues with switch too).



Help is solicited please.
ic57369k
 
Posts: 17
Joined: Sat Jun 24, 2017 4:19 am

Re: ONLYOFFICE IS NOT AVAILABLE ERROR MESSAGE

Postby Maxim » Mon Jul 03, 2017 7:04 am

The topic is locked, this is dublicate of this one
Maxim
 
Posts: 1170
Joined: Tue Oct 11, 2016 2:34 pm


Return to Document Server

Who is online

Users browsing this forum: No registered users and 2 guests