Try the fastest and simplest way to install ONLYOFFICE

Onlyoffice - Nextcloud app

Suggestions on Document Server Installation/Functionality

Re: Onlyoffice - Nextcloud app

Postby Maxim » Thu Mar 09, 2017 12:02 pm

Hello everybody!
Now OnlyOffice supports Nextcloud!
This is one plugin for Own Cloud and Nextcloud
Maxim
 
Posts: 677
Joined: Tue Oct 11, 2016 2:34 pm

Re: Onlyoffice - Nextcloud app

Postby igsrv » Mon Mar 13, 2017 9:19 pm

hi, sorry for my bad english,

i have the same issue in this thread viewtopic.php?f=5&t=8662


the difference is that i have two separate server

fisrt server : nextcloud server only listen https

second server : documentserver with linux debian installation


but i know the problem, there is the output of /var/log/onlyoffice/documentserver/docservice/out.log


[ERROR] nodeJS - postData error: docId = 24007451489417152;url = http://MY-NEXTCLOUD-SERVER/index.php/ap ... ...........

and this part

Error: connect ECONNREFUSED MY-NEXT-CLOUD-IP:80


it seems that the documentserver cant communicate with nextcloud in this way

but i have my nextcloud server only in https mode through load balancer , i mean only port 443 is open, the 80 port is closed for security reasons

do i have to modify something on nextcloud-onlyoffice app, or on the documentserver to change the communication from http to https?

thanks
igsrv
 
Posts: 2
Joined: Mon Mar 13, 2017 8:59 pm

Re: Onlyoffice - Nextcloud app

Postby Maxim » Tue Mar 14, 2017 7:18 am

Hello
How to enable https on Document Server.
As i understand you should enable https on both servers NextCloud and Document server.
The default path that the onlyoffice application is configured to look for the SSL certificates is at /var/www/onlyoffice/Data/certs.
The /var/www/onlyoffice/Data/ path is the path of the data store, which means that you have to create a folder named certs inside /var/www/onlyoffice/Data/ and copy the files into it and as a measure of security you will update the permission on the onlyoffice.key file to only be readable by the owner.
Maxim
 
Posts: 677
Joined: Tue Oct 11, 2016 2:34 pm

Re: Onlyoffice - Nextcloud app

Postby igsrv » Fri Mar 17, 2017 4:20 pm

Maxim wrote:Hello
How to enable https on Document Server.
As i understand you should enable https on both servers NextCloud and Document server.
The default path that the onlyoffice application is configured to look for the SSL certificates is at /var/www/onlyoffice/Data/certs.
The /var/www/onlyoffice/Data/ path is the path of the data store, which means that you have to create a folder named certs inside /var/www/onlyoffice/Data/ and copy the files into it and as a measure of security you will update the permission on the onlyoffice.key file to only be readable by the owner.




Hi thanks for you reply

I have already https on both servers and working well, but the problem i guess is with the callbackurl, because i tested opening the port 80 and redirect the connections to the port 443 on the firewall trying to establish a connection without any error, but the apps still display the warning "the document could noty be saved...." and the log file change the error message now is like this






[ERROR] nodeJS - postData error: docId = 24007411489415733;url = http://MYNEXTCLOUDSERVER/index.php/apps ... jayJ9;data = {"key":"24007411489415733","status":1,"users":["273f5066-1644-1033-96b6-c1d2ac419103"],"actions":[{"type":1,"userid":"273f5066-1644-1033-96b6-c1d2ac419103"}]}
Error: Error response: statusCode:302 ;body:

at Request._callback (/var/www/onlyoffice/documentserver/server/Common/sources/utils.js:255:18)
at Request.self.callback (/var/www/onlyoffice/documentserver/server/Common/node_modules/request/request.js:187:22)
at emitTwo (events.js:106:13)
at Request.emit (events.js:191:7)
at Request.<anonymous> (/var/www/onlyoffice/documentserver/server/Common/node_modules/request/request.js:1126:10)
at emitOne (events.js:96:13)
at Request.emit (events.js:188:7)
at IncomingMessage.<anonymous> (/var/www/onlyoffice/documentserver/server/Common/node_modules/request/request.js:1046:12)
at IncomingMessage.g (events.js:291:16)
at emitNone (events.js:91:20)
at IncomingMessage.emit (events.js:185:7)



If you see the url at the begining shows an "http" link, but my server is only works with https, i dont know why happens this, and the error code 302 is an redirect of the firewall, but i can open the document after the warning message but sometimes saves the document, not all times, its very annoying
igsrv
 
Posts: 2
Joined: Mon Mar 13, 2017 8:59 pm

Previous

Return to Document Server

Who is online

Users browsing this forum: No registered users and 1 guest