Try the fastest and simplest way to install ONLYOFFICE

ONLYOFFICE™ is not available. Please contact us at support@o

Issues during installation and related to database

ONLYOFFICE™ is not available. Please contact us at support@o

Postby lextar » Tue Feb 06, 2018 10:10 am

Hi,
I Upgraded Onlyoffice community server for Windows to the latest version.
Now, when I try to open any document I get this error:

ONLYOFFICE™ is not available. Please contact us at support@onlyoffice.com.
lextar
 
Posts: 20
Joined: Fri Feb 03, 2017 9:51 am

Re: ONLYOFFICE™ is not available. Please contact us at suppo

Postby lextar » Tue Feb 06, 2018 10:24 pm

Hi,
I found the problem under
Integration and Document service.

If I remove /ds-vpath/ from
/web-apps/apps/api/documents/api.js

and put this string instead:
http://localhost:8083/web-apps/apps/api ... nts/api.js

It works on the local server, but obiouvsly not on other browsers. How can I fix that ds-vpath issue? Under IIS I see a rewrite rule. It redirects all the traffic under localhost... How can I change that?
lextar
 
Posts: 20
Joined: Fri Feb 03, 2017 9:51 am

Re: ONLYOFFICE™ is not available. Please contact us at suppo

Postby Maxim » Wed Feb 07, 2018 7:43 am

Hello lextar!
It should be like this
Document Service Location on Windows.png
Document Service Location on Windows.png (48.04 KiB) Viewed 2929 times

Document Editing Service Address - /ds-vpath/web-apps/apps/api/documents/api.js
Document Command Service Address - http://localhost:8083/coauthoring/CommandService.ashx
Document Storage Service Address - http://localhost:8083/FileUploader.ashx
Document Conversion Service Address - http://localhost:8083/ConvertService.ashx
Docbuilder Service Address - http://localhost:8083/docbuilder
Community Server Address - http://localhost
What is Onlyoffice version installed on your server?
Maxim
 
Posts: 1747
Joined: Tue Oct 11, 2016 2:34 pm

Re: ONLYOFFICE™ is not available. Please contact us at suppo

Postby lextar » Wed Feb 07, 2018 1:36 pm

Hello Maxim,
I tried but I can't save it by putting the string you indicated:

Schermata 2018-02-07 alle 14.34.14.png
Schermata 2018-02-07 alle 14.34.14.png (217.5 KiB) Viewed 2925 times


Could be a problem related to IIS' redirect setting?
I tried to edit it by replacing "localhost" with "HTTP_HOST" but still nothing:
Schermata 2018-02-07 alle 14.35.48.png
IIS ds-vpath redirect
Schermata 2018-02-07 alle 14.35.48.png (188.98 KiB) Viewed 2925 times
lextar
 
Posts: 20
Joined: Fri Feb 03, 2017 9:51 am

Re: ONLYOFFICE™ is not available. Please contact us at suppo

Postby lextar » Sat Feb 10, 2018 10:02 am

any idea?
lextar
 
Posts: 20
Joined: Fri Feb 03, 2017 9:51 am

Re: ONLYOFFICE™ is not available. Please contact us at suppo

Postby Maxim » Mon Feb 12, 2018 8:03 am

Hello lextar!
"One more step. Please complete the security check to access crm.monofase.net"
so you should put Community Server Address - http://localhost.
Also please specify how did you update Onlyoffice?
Maxim
 
Posts: 1747
Joined: Tue Oct 11, 2016 2:34 pm

Re: ONLYOFFICE™ is not available. Please contact us at suppo

Postby lextar » Mon Feb 12, 2018 10:38 am

Hello Maxim!
Just tried, I get this error:

"Api url: Service is not defined"
See screenshot

Schermata 2018-02-12 alle 11.37.21.png
Schermata 2018-02-12 alle 11.37.21.png (222.96 KiB) Viewed 2842 times


I can't change the settings!
I update simply by installing the latest version of community server for Windows.
Tried also to uninstall and then reinstall OnlyOffice and IIS service. No luck :(
lextar
 
Posts: 20
Joined: Fri Feb 03, 2017 9:51 am

Re: ONLYOFFICE™ is not available. Please contact us at suppo

Postby Maxim » Mon Feb 12, 2018 11:04 am

Hello extar!
Did you install Document Server? Where is Document Server?
I have just noticed that you mentioned Onlyoffice Community server. At first glance i thought that you meant Onlyoffice Community Edition.
If you didn't install Document Server - you should. But you should install it on another server.
Maxim
 
Posts: 1747
Joined: Tue Oct 11, 2016 2:34 pm

Re: ONLYOFFICE™ is not available. Please contact us at suppo

Postby lextar » Mon Feb 12, 2018 5:06 pm

Sorry, but you are right. I mentioned the wrong version.

I installed Community Edition, including the Document server.

I got it working now but by putting the Document server's Public IP with port 8083 in the "Document service URL"...
I think it's not a great idea, but at the moment is the only solution I found.
lextar
 
Posts: 20
Joined: Fri Feb 03, 2017 9:51 am

Re: ONLYOFFICE™ is not available. Please contact us at suppo

Postby Maxim » Thu Feb 22, 2018 10:53 am

Hello lextar!
It means that there is no permission for localhost.
Maybe you should configure IIS.
Also try to check file hosts (c:\windows\system32\drivers\etc\hosts), there must be smth. like this in config
Code: Select all
# localhost name resolution is handled within DNS itself.
   127.0.0.1       1localhost
   ::1             1localhost
Maxim
 
Posts: 1747
Joined: Tue Oct 11, 2016 2:34 pm


Return to Installation / Database

Who is online

Users browsing this forum: No registered users and 2 guests