Try the fastest and simplest way to install ONLYOFFICE

Missing allfonts.js

Issues during installation and related to database

Missing allfonts.js

Postby sbeaver » Sat Mar 11, 2017 4:24 am

Further to my earlier post about document server stalling at the "Loading" message, I have discovered an error message:

2017/03/10 22:04:25 [error] 2626#2626: *92 open() "/var/www/onlyoffice/documentserver/sdkjs/common/AllFonts.js" failed (2: No such file or directory), client: 172.21.2.11, server: , request: "GET /2017-02-17-15-53/sdkjs/common/AllFonts.js HTTP/1.1", host: "onlyoffice-ds.test.com", referrer: "http://onlyoffice-ds.test.com/2017-02-17-15-53/web-apps/apps/documenteditor/main/index.html?_dc=2017-02-17-15-53&lang=en-US&customer=ONLYOFFICE&frameEditorId=iframeEditor"

In my nginx logs. The file AllFonts.js is not present on the document server.
sbeaver
 
Posts: 6
Joined: Fri Mar 10, 2017 10:04 pm

Re: Missing allfonts.js

Postby Maxim » Mon Mar 13, 2017 9:41 am

Hello sbeaver!
It's not good. You should check your permissions, iptables or firewalls.
Maxim
 
Posts: 777
Joined: Tue Oct 11, 2016 2:34 pm

Re: Missing allfonts.js

Postby sbeaver » Mon Mar 13, 2017 1:59 pm

No firewall is in place, and the permissions are correctly set.

I was able to visit the public document server at https://doc.onlyoffice.com/welcome/, make a copy of the AllFOnts.js file on that site and copy it to my document server. My OnlyOffice installation now works correctly.

I assume that AllFont/js was not being generated during the installation process or is missing from the installer package
sbeaver
 
Posts: 6
Joined: Fri Mar 10, 2017 10:04 pm

Re: Missing allfonts.js

Postby Maxim » Tue Mar 14, 2017 6:21 am

Hello sbeaver!
I suppose this issue is solved now. Document Server works correctly. I'm glad to hear it.
Maxim
 
Posts: 777
Joined: Tue Oct 11, 2016 2:34 pm

Re: Missing allfonts.js

Postby sbeaver » Tue Mar 14, 2017 12:24 pm

NO

On a fresh install, the file AllFont.js is missing from Document server. Would you please explain how this file is generated and why it is not present in the current installer version?
sbeaver
 
Posts: 6
Joined: Fri Mar 10, 2017 10:04 pm

Re: Missing allfonts.js

Postby Maxim » Tue Mar 14, 2017 1:40 pm

Please specify what instruction did you use to install? This one?
Maxim
 
Posts: 777
Joined: Tue Oct 11, 2016 2:34 pm

Re: Missing allfonts.js

Postby sbeaver » Tue Mar 14, 2017 8:09 pm

sbeaver
 
Posts: 6
Joined: Fri Mar 10, 2017 10:04 pm

Re: Missing allfonts.js

Postby Maxim » Wed Mar 15, 2017 7:32 am

Hello sbeaver!
Please send us logs /var/log/onlyoffice/documentserver.
support@onlyoffice.com with link to your post in subject or attach archive to your post here.
Maybe there is a font in your system which causes errors of OO installation.
Maxim
 
Posts: 777
Joined: Tue Oct 11, 2016 2:34 pm


Return to Installation / Database

Who is online

Users browsing this forum: No registered users and 4 guests