Page 1 of 1

Error when compiling document server v4.1.0, Ubuntu 16.04

PostPosted: Wed Sep 14, 2016 2:28 pm
by keepo
core version 4.1.0

I was following this article to compile document server locally

http://helpcenter.onlyoffice.com/server ... -code.aspx

but i got this error,

../memorystream.h:39:16: fatal error: v8.h: No such file or directory

and after I install libv8-dev, i got another one

../memorystream.h:40:37: fatal error: libplatform/libplatform.h: No such file or directory

Did I miss something?

Re: Error when compiling document server v4.1.0, Ubuntu 16.0

PostPosted: Fri Sep 16, 2016 3:45 pm
by Eugenie
Hello,

Could you describe your actions step by step and specify the exact moment (step) the issue appears.

We will be gald to help you.

Re: Error when compiling document server v4.1.0, Ubuntu 16.0

PostPosted: Sat Sep 17, 2016 9:38 am
by keepo
Eugenie wrote:Hello,

Could you describe your actions step by step and specify the exact moment (step) the issue appears.

We will be gald to help you.


I follow compile icu, install v8 as module.

Then build the core, "cd core && make" and I got that error.

Re: Error when compiling document server v4.1.0, Ubuntu 16.0

PostPosted: Wed Sep 21, 2016 11:55 am
by Pavel.Lobashov
@keepo
Hi, I re-check all the steps prior
Code: Select all
cd core && make
and it works fine for me on Ubuntu 16.04
Could you check that step
Code: Select all
CFLAGS="-fPIC" CXXFLAGS="-fPIC" make native
for v8 finished correctly?
As far as I understand on some systems there is this error while trying to compile v8
Code: Select all
unsupported reloc 42 against global symbol __gmon_start__

and I fixed like mention in this thread
by executing command
Code: Select all
rm third_party/binutils/Linux_x64/Release/bin/ld.gold
ln -s /usr/bin/ld.gold third_party/binutils/Linux_x64/Release/bin/ld.gold

Re: Error when compiling document server v4.1.0, Ubuntu 16.0

PostPosted: Wed Sep 21, 2016 1:47 pm
by Pavel.Lobashov
@keepo
We reproduced problem on one system, looking for a way to fix it.

Re: Error when compiling document server v4.1.0, Ubuntu 16.0

PostPosted: Thu Sep 22, 2016 7:16 am
by keepo
Pavel.Lobashov wrote:@keepo
Hi, I re-check all the steps prior
Code: Select all
cd core && make
and it works fine for me on Ubuntu 16.04
Could you check that step
Code: Select all
CFLAGS="-fPIC" CXXFLAGS="-fPIC" make native
for v8 finished correctly?
As far as I understand on some systems there is this error while trying to compile v8
Code: Select all
unsupported reloc 42 against global symbol __gmon_start__

and I fixed like mention in this thread
by executing command
Code: Select all
rm third_party/binutils/Linux_x64/Release/bin/ld.gold
ln -s /usr/bin/ld.gold third_party/binutils/Linux_x64/Release/bin/ld.gold


Did you compile 4.1.0 or above? I have no problem compiling 4.0.3 version.

Re: Error when compiling document server v4.1.0, Ubuntu 16.0

PostPosted: Tue Sep 27, 2016 3:12 pm
by Eugenie
Our developers are working on solving the issue.

We are sorry for the inconveniences!