Try the fastest and simplest way to install ONLYOFFICE

Invite User uses the IP and not hostname

Adding a first (new) user / portal activity notifications / email / chat

Invite User uses the IP and not hostname

Postby TTownsend » Wed Jan 04, 2017 3:51 am

Hello,


I just installed Community Server on a Ubuntu 16.04 host behind a router.
Everything is working fine, except that the invite emails are showing the IP address of the server instead of a host name.
Currently, the email is sent out with the URL link as http://192.168.0.211, when it should be sending out http://my.hostname.com.
I've changed the custom DNS setting to my host name, but that seems to make no difference.

Without setting the hostname in the invite there is no way my users outside my LAN can register on the system.

Would someone please explain how to change this so it uses the hostname when inviting users?

Many thanks in advance!

Trevor
TTownsend
 
Posts: 12
Joined: Wed Jan 04, 2017 3:45 am

Re: Invite User uses the IP and not hostname

Postby Maxim » Wed Jan 04, 2017 8:22 am

Hello TTownsend!
1. Please specify what instruction did you use to install OnlyOffice?
2. Email module in Community Server works like a Mail Aggregator it doesn't have own smtp/pop server.
3. See here
Maxim
 
Posts: 653
Joined: Tue Oct 11, 2016 2:34 pm

Re: Invite User uses the IP and not hostname

Postby TTownsend » Wed Jan 04, 2017 2:45 pm

Hello Maxim,

I installed Community Server and Document Server each in their own Ubuntu virtual machine under VMWare Workstation.

The problem I have is that the Invite uses an internal LAN IP address in the email sent to invited users, and not the hostname.

Thanks for the link, but this doesn't appear to address my problem - the link addresses configuration of the email aggregator function, not how to specify the server address in the user invitation.

Do you know how to set that address?

Best,
Trevor
TTownsend
 
Posts: 12
Joined: Wed Jan 04, 2017 3:45 am

Re: Invite User uses the IP and not hostname

Postby Maxim » Thu Jan 05, 2017 10:17 am

Hello TTownsend!
Try to enter your portal with your domain name http://my.hostname.com and make the invite from there (not from your IP address).
Maxim
 
Posts: 653
Joined: Tue Oct 11, 2016 2:34 pm

Re: Invite User uses the IP and not hostname

Postby TTownsend » Mon Jan 09, 2017 4:12 pm

Thanks Maxim.

So here's what I did:

Changed to a custom domain in Setup.
Created invitation. (verified that LAN IP shows as the link in the invitation).
Logged out from LAN IP address.
Logged in using a public domain name.
Created invitation. (Verified that public domain name shows in the invitation).
Paused to have a beer and consider the universe.
Decided it must be an issue with a global variable defined at user login.
Decided to ask you this: Maybe default to use FQDN as the response link in invite and not upstream addresses (if LAN or give choice?) a global variable picked up at user login that give the current response link the for invitee?
TTownsend
 
Posts: 12
Joined: Wed Jan 04, 2017 3:45 am

Re: Invite User uses the IP and not hostname

Postby Maxim » Tue Jan 10, 2017 7:42 am

Hello TTownsend!
After your pause and thoughts about The Ultimate Question of Life, the Universe, and Everything ;) .....you still have that issue i suppose. Maybe you should try to install Community Edition for Docker on clean machine, i mean not on VMWare.
Maxim
 
Posts: 653
Joined: Tue Oct 11, 2016 2:34 pm

Re: Invite User uses the IP and not hostname

Postby TTownsend » Tue Jan 10, 2017 12:04 pm

Hi Maxim,

VMWare is our chosen solution to avoid higher hardware costs, so a bare metal install is not an option.

In any case the situation seems to have resolved.

Back to pondering the universe ... :D
TTownsend
 
Posts: 12
Joined: Wed Jan 04, 2017 3:45 am


Return to Notification issues

Who is online

Users browsing this forum: No registered users and 1 guest