Try the fastest and simplest way to install ONLYOFFICE

Projects not loading after update

Issues during installation and related to database

Projects not loading after update

Postby 1337hium » Tue Dec 20, 2016 4:07 pm

Hi

I updated the Community Server today from 8.7.279 to 8.9.2.19.
Everything works fine except for the Projects. It just loads endless...

Any Idea how i can fix this?
1337hium
 
Posts: 10
Joined: Wed Dec 30, 2015 8:56 am

Re: Projects not loading after update

Postby Maxim » Wed Dec 21, 2016 8:54 am

Hello!
There are some variants of solution:
1. Try to restart community server docker container.
2. Find the community server container use
Code: Select all
docker ps -a
than get inside of the container
Code: Select all
docker attach "container_id"
and restart monoserve and nginx
Code: Select all
service monoserve restart
service monoserve2 restart
service nginx restart

3. Delete all your containers and update your system again using the provided script. Don't forget to delete old installation script!
Download Enterprise Edition Docker script file.
Code: Select all
wget http://download.onlyoffice.com/install/enterprise-install.sh

and than run installation with necessary parameters you need
Code: Select all
bash enterprise-install.sh

Remember! You should have mapped folders to backup your data.
Maxim
 
Posts: 523
Joined: Tue Oct 11, 2016 2:34 pm

Re: Projects not loading after update

Postby 1337hium » Wed Dec 21, 2016 9:23 am

Hi Maxim

Sorry, i forgot to mention it, i use Ubuntu 14.04 and the install from the repo.
I also saw, that i can't download the Documents anymore...
1337hium
 
Posts: 10
Joined: Wed Dec 30, 2015 8:56 am

Re: Projects not loading after update

Postby Maxim » Wed Dec 21, 2016 11:29 am

Hi 1337hium!
What about your Community Server? Works fine?
Maxim
 
Posts: 523
Joined: Tue Oct 11, 2016 2:34 pm

Re: Projects not loading after update

Postby 1337hium » Wed Dec 21, 2016 12:22 pm

Hi Maxim

Everything works besides Projects and Downloading files/Documents.

Which log can i check for Errors?
1337hium
 
Posts: 10
Joined: Wed Dec 30, 2015 8:56 am

Re: Projects not loading after update

Postby 1337hium » Fri Dec 23, 2016 10:08 am

So, i did a fresh install of the Community Server (8.9.2.19) and Document Server (4.2). After that i restored the Database and the Data Folder.

Now i have the Problem, that i only could edit a Document for 1 Time. When i try to edit it a 2nd time, there is a error "Fehler beim Starten der Dateibearbeitung" (roughly translated, can't start Editing)

Any hints where i can start searching?
1337hium
 
Posts: 10
Joined: Wed Dec 30, 2015 8:56 am

Re: Projects not loading after update

Postby Maxim » Fri Dec 23, 2016 11:34 am

Hello!
What tutorial you followed to install OnlyOffice?
Maxim
 
Posts: 523
Joined: Tue Oct 11, 2016 2:34 pm

Re: Projects not loading after update

Postby 1337hium » Fri Dec 23, 2016 12:34 pm

1337hium
 
Posts: 10
Joined: Wed Dec 30, 2015 8:56 am

Re: Projects not loading after update

Postby Maxim » Wed Dec 28, 2016 8:51 am

Hello!
I suppose that there is no correct connection between servers, i mean that if we want to edit the files we should have two linux servers with opened ports (80 for plain HTTP, 443 when HTTPS is enabled and 5222 for XMPP-compatible instant messaging client), without stoping connection firewall. Please try to check editing service without your database, i mean on clean OnlyOffice installation. Just to be sure that Servers work properly.
Maxim
 
Posts: 523
Joined: Tue Oct 11, 2016 2:34 pm


Return to Installation issues

Who is online

Users browsing this forum: No registered users and 1 guest